Jira 7.6.3 not starting over SSL after upgrading from 7.6.2 Edited

Hi community, today I noticed there was an update for Jira (7.6.3) and applied it, but after upgrade Jira from version 7.6.2 it will not start over SSL, I did rewrite server.xml and web.xml files but no luck, if I remove SSL config Jira starts normally but I need it through SSL, any idea?

in catalina.out i noticed following warning:

2018-01-09 16:10:17,599 HealthCheck:thread-3 ERROR      [c.a.t.j.healthcheck.support.GadgetFeedUrlHealthCheck] An error occurred when performing the Gadget feed URL healthcheck

org.apache.http.conn.ConnectTimeoutException: Connect to jiraserver-url:8443 [jiraserver-url/ip] failed: Read timed out

09-Jan-2018 16:25:57.249 INFO [http-nio-8080-exec-5] org.apache.coyote.http11.Http11Processor.service Error parsing HTTP request header

 Note: further occurrences of HTTP header parsing errors will be logged at DEBUG level.

 java.lang.IllegalArgumentException: Invalid character found in method name. HTTP method names must be tokens

at org.apache.coyote.http11.Http11InputBuffer.parseRequestLine(Http11InputBuffer.java:462)

at org.apache.coyote.http11.Http11Processor.service(Http11Processor.java:667)

at org.apache.coyote.AbstractProcessorLight.process(AbstractProcessorLight.java:66)

at org.apache.coyote.AbstractProtocol$ConnectionHandler.process(AbstractProtocol.java:802)

at org.apache.tomcat.util.net.NioEndpoint$SocketProcessor.doRun(NioEndpoint.java:1410)

at org.apache.tomcat.util.net.SocketProcessorBase.run(SocketProcessorBase.java:49)

at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142)

at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617)

at org.apache.tomcat.util.threads.TaskThread$WrappingRunnable.run(TaskThread.java:61)

at java.lang.Thread.run(Thread.java:745)

 

2018-01-09 16:25:58,696 Caesium-1-3 INFO      [c.a.j.p.h.service.ping.RefreshConnectionStatusJobHandler] Running RefreshConnectionStatusJobHandler...

2018-01-09 16:26:36,160 Caesium-1-3 INFO      [c.a.jira.upgrade.UpgradeScheduler] Running scheduled upgrades

2018-01-09 16:26:36,181 Caesium-1-3 INFO      [c.a.jira.upgrade.LoggingUpgradeService] run upgrades has started

2018-01-09 16:26:36,494 Caesium-1-3 INFO      [c.a.j.upgrade.util.BuildNumberDao] Setting current build number to 76005

2018-01-09 16:26:36,515 Caesium-1-3 DEBUG      [c.a.activeobjects.osgi.ActiveObjectsServiceFactory] getService bundle [com.atlassian.jira.plugins.webhooks.jira-webhooks-plugin]

2018-01-09 16:26:36,521 Caesium-1-3 INFO      [c.a.jira.upgrade.UpgradeIndexManager] There is no reindex requests of type [IMMEDIATE, DELAYED] so none will be run

2018-01-09 16:26:36,521 Caesium-1-3 INFO      [c.a.j.upgrade.util.BuildNumberDao] Setting current version to 7.6.3

2018-01-09 16:26:36,529 Caesium-1-3 INFO      [c.a.j.upgrade.util.BuildNumberDao] Setting downgrade version to 7.1.2

2018-01-09 16:26:36,540 Caesium-1-3 INFO      [c.a.jira.upgrade.LoggingUpgradeService] run upgrades has finished successfully, and took 359 milliseconds to process.

2018-01-09 16:26:36,541 Caesium-1-3 INFO      [c.a.jira.upgrade.UpgradeScheduler] JIRA upgrades completed successfully

2018-01-09 16:26:36,545 Caesium-1-3 INFO      [c.a.jira.upgrade.UpgradeScheduler] Plugins upgrades completed successfully

2018-01-09 16:26:36,546 Caesium-1-3 INFO      [c.a.jira.upgrade.UpgradeIndexManager] Reindexing is not allowed after this upgrade and there is no immediate reindex requests

2018-01-09 16:26:42,938 Caesium-1-4 DEBUG      [c.a.activeobjects.osgi.ActiveObjectsServiceFactory] getService bundle [com.atlassian.troubleshooting.plugin-jira]

 

Please help,

1 answer

This widget could not be displayed.

Hi William,

From similar issues I have seen and have been reported in the Community this usually happens when the certificates were not installed in the Java Keystore.  Can you verify the certificates are in the proper Java Keystore and if not please follow the Command Line Installation section of Running JIRA applications over SSL or HTTPS to add the certificates and try again.

Cheers,

Branden

JKS file is the same file that was working before when running version 7.6.2 and nothing changed just updated to 7.6.3 and Jira stopped working... any other advice?

Since new version , do I have to run any special process for importing current jks (working previosly) file to keystone?

keytool -list -alias jira -keystore jira.jks

jira, Jan 8, 2018, PrivateKeyEntry, 

Certificate fingerprint (SHA1): E6:39:C7:6C:BB:1B:25:96:DE:AC:3D:27:78:E9:29:5E:28:3B:14:31

I reinstalled v7.6.3 from scratch (erased everything) and still not able to run Jira over SSL using working jira.jks file from previous version 7.6.2 (same server). Seems issue with version?

well after destroying everything and perform a clean install of 7.6.2 then upgrade to 7.6.3 I noticed there is a conflict with protocol: 

09-Jan-2018 18:57:03.843 WARNING [main] org.apache.tomcat.util.net.SSLUtilBase.getEnabled Some of the specified [protocols] are not supported by the SSL engine and have been skipped: [[TLSv1.3]]

 

after removed that from config file everything works, but I lost all my info :(

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Tuesday in Jira

What modern development practices are at the heart of how your team delivers software?

Hey Community mates! Claire here from the Software Product Marketing team. We all know software development changes rapidly, and it's often tough to keep up. But from our research, we've found the h...

202 views 1 3
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you