Jira 7.1.0 plugin incompatablity problem

This question is in reference to Atlassian Developer Documentation: BundleException with no bundle constraint specified

Hi everyone,

I have want to upgrade plugin from JIRA 6.4.5 to JIRA 7.1.0. When I upload the plugin i'm getting the following error:

Any suggestions would be highly appreciated. I have tried most solutions online to no vail.

 at java.lang.Thread.run(Thread.java:745)

Caused by: org.osgi.framework.BundleException: Uses constraint violation. Unable to resolve bundle revision za.co.infowarestudios.jiraplugins.infoware-quote-plugin [185.0] because it is exposed to package 'org.apache.velocity.context' from bundle revisions org.apache.felix.framework [0] and org.apache.servicemix.bundles.velocity [15.0] via two dependency chains.

 

Chain 1:

  za.co.infowarestudios.jiraplugins.infoware-quote-plugin [185.0]

    import: (&(osgi.wiring.package=org.apache.velocity.context)(version>=1.6.4.atlassian_7)(version<=1.6.4.atlassian_7))

     |

  org.apache.felix.framework [0]

Chain 2:

  za.co.infowarestudios.jiraplugins.infoware-quote-plugin [185.0]

    import: (osgi.wiring.package=org.springframework.web.servlet.config.annotation)

     |

    export: osgi.wiring.package=org.springframework.web.servlet.config.annotation; uses:=org.apache.velocity.app

  org.apache.servicemix.bundles.spring-webmvc [14.0]

    import: (&(osgi.wiring.package=org.apache.velocity.app)(version>=1.7.0)(!(version>=2.0.0)))

     |

    export: osgi.wiring.package=org.apache.velocity.app; uses:=org.apache.velocity.context

    export: osgi.wiring.package=org.apache.velocity.context

  org.apache.servicemix.bundles.velocity [15.0]

 at org.apache.felix.framework.Felix.resolveBundleRevision(Felix.java:3980)

 at org.apache.felix.framework.Felix.startBundle(Felix.java:2037)

 at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:955)

 at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:942)

 at com.atlassian.plugin.osgi.factory.OsgiPlugin.enableInternal(OsgiPlugin.java:400)

1 answer

0 vote

You'll need to contact the vendors of the add-on.  It's not compatible with JIRA 7 and needs updating and recompiling.

I'd go to https://marketplace.atlassian.com/plugins/za.co.infowarestudios.jiraplugins.infoware-quote-plugin/server/support and try the linked issue tracker to see if you can raise it there.

Hi Nick,

I'm the one developing the plugin, sorry didn't mention it. I have checked my pom file but don't know what i'm missing

Ok, I'm not sure how to fix it either.  I've run into something similar in my add-ons a couple of times, and fixed it mostly by trial and error - removing imports that it refers to so that it's only trying to us a single library, but I don't think that's a "good" approach (it shouldn't be!)

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published yesterday in Jira

5 ways you can make the most of Jira Software and Bitbucket Cloud

As part of the Bitbucket product team I'm always interested in better understanding what kind of impact the use of our tools have on the way you work. In a recent study we conducted of software devel...

35 views 0 4
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you