Jira 6.0.2 Application Navigator is missing the linked applications

From the Admin Application Navitator Page: "Linked applications are automatically configured in the application navigator for you, and you can't delete them."

However, I have Confluence and Fisheye configured as linked applications but they don't show up in the Application Navigator bar.

Ideas?

6 answers

Have you got JIRA and Confluence set up to run via SSL?

If so, your Application Links may be misconfigured: I was able to solve my problem by installing a new SSL certificate (my previous one was untrusted), and re-creating the application links.

This may also be a factor: https://jira.atlassian.com/browse/JRA-34550

Let me know if that helps solve your problem.

0 votes

Is the application navigator option available in the top left at all? Does disabling/enabling the application navigator plugin resolve the issue?

Prior to manually adding a test URl the three horizontal line image did not show up at all. After putting in a test url it shows up but still doesn't show the linked applications (fisheye and confluence).

Which plugin should I disable/enable? There are only 6 million in jira at this point. I don't see one that sounds like the one I want.

I'm having the same problem: all of my Atlassian apps are linked, and the links are functioning, but none of them are displaying in each others' Application Navigator (which just doesn't show up, unless I add something manually).

I have the same issue. I use JIRA and confluence ondemand. For last 1 week, Application navigator is gone. Probably due to latest update. Then able to configure manually from JIRA to confluence. But couldn't do from confluence to JIRA because there is no section in confluence admin.

It looks like the latest update on ondemand fixed all issues I had. But I still have a minor issue. Before this fix, I had manually added an application navigator item in JIRA to link to confluence. After this update, I have duplicate confluence links. I couldn't delete one of them. Then I marked one of them as hidden. Now I couldn't update it. Any solution for this issue?

This is still an issue on the current version of JIRA On Demand (v1000.148.2).  I have found a workaround for admins: go into the Application Navigator configuration screen and hit the 'refresh' icon at the top right of the list.  This will bring back all of the listings and the navigator will work fine.  I have found this to take place after an overnight update of plugins requires a reindex.  I perform the reindex first and then refresh the app list to restore the Application Navigator back to usefulness.

Suggest an answer

Log in or Join to answer
Community showcase
Sarah Schuster
Posted Jan 29, 2018 in Jira

What are common themes you've seen across successful & failed Jira Software implementations?

Hey everyone! My name is Sarah Schuster, and I'm a Customer Success Manager in Atlassian specializing in Jira Software Cloud. Over the next few weeks I will be posting discussion topics (8 total) to ...

2,864 views 12 18
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot