Jira 5.0.4: Why can't i connect to an AD server over SSL?

I setup connection to AD over an SSL connection. Quick test is OK, when i do what looks like a more thorough test, it fails leaving me with this error: Test basic connection : Failed

fqdn.server.name:636; nested exception is javax.naming.CommunicationException: fqdn.server.name:636 [Root exception is java.lang.ClassNotFoundException: com.atlassian.crowd.directory.ssl.LdapHostnameVerificationSSLSocketFactory]
The only thing in my setup that is different is that i resolve the LDAP server's name through the hosts file. Do i maybe need to have the LDAP server's FQDN name in DNS or will the hostfile be sufficient?
Quite actually this is two questions into one, but hope someone is able to point me in the right direction.

3 answers

This widget could not be displayed.

Hi Eddie,

From the root cause of the error you are receiving, and the fact that the quick test is successful, I susepct that you are facing the bug described here: https://jira.atlassian.com/browse/JRA-27347

However, if that is the case then that is good news because the bug is actually that the test fails but the LDAPS connection and the synchronisation are successful. Therefore I would suggest you start by checking whether the connection and synchronisation are working correctly, and if not then I would suggest that you open a support ticket so that we can investigate the cause of this issue.

All the best,
John

Hello John,

Thanks for the help.

I tried testing the synchronization just now, and synchronization failed:

Last synchronised at 7/26/12 8:48 AM (took 0s).

Synchronisation failed. See server logs for details.

From the looks of this, i can safely say i'm probably not having this bug. Is there a log somewhere that can point us in the right direction?

Would yoiu you know if this particular bug is fixed in version 5.1?

No it is not fixed and it causing lots of problems. Feel free to comment on the bug tracker.

Thanks Sorin,

I will comment on the bug tracker. Would be nice if they fixed this one. Something may be causing this, but as long as i don't know what this error points to (if an error was given in the first place) i have not much to investigate on.

This widget could not be displayed.

No answers so far... Will upgrade to version 5.1 and see what happens then

This widget could not be displayed.

I tried to add the LDAP FQDN in the /etc/hosts but that was not enough to fix the problem.

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted yesterday in New to Jira

Are you planning to trial, or are currently trialling Jira Software? - We want to talk to you!

Hello! I'm Rayen, a product manager at Atlassian. My team and I are working hard to improve the trial experience for Jira Software Cloud. We are interested in   talking to 20 people planning t...

46 views 1 0
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you