Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

JQL Description IS Empty Does Not Work

I'm trying to setup an automat but it doesn't work and I'm pretty sure it's because this JQL doesn't work but I don't understand why, if this is not empty then what is. I also tried is NULL. Screen Shot 2020-12-18 at 1.19.34 AM.png

The automation interface only has these options so I'm not sure how to proceed... any suggestions?

Screen Shot 2020-12-18 at 1.21.03 AM.png

4 answers

Hello @Nick ,


in an automation rule, the Issue fields condition works for me.

Screenshot 2020-12-18 at 10.13.34.png
Question: you indicate in your question both "is empty" and "is not empty". Which one doesn't work for you?
And what do you want to do with the automation rule?

 

regards, Marco

@Marco Brundel I was trying to show the issue I can't find so for the screenshot I put "not empty." For testing purposes I had trigger set to "on edit" and for some reason the description does not show as empty, but if I use that same logic "on create" it worked exactly as expected.

Basically I setup a automatic template, so when we create issue we will create them blank so the automat will then insert our template since Jira doesn't have this feature and the 3rd party we use is a little clunky in it's approach.

0 votes

Hi @Nick 

 

image.png

The following email was received

image.png

0 votes
Daniel Ebers Community Leader Dec 25, 2020

Hi Nick,

could you please show us your rule like in the screenshots of Marco and Kagithala along with the output of the log like showed in the screenshot of Kagithala?

That will help in digging deeper :)

Thanks,
Daniel

0 votes

Maybe there are some line breaks or spaces in your description? it's weird that the JQL search would show it up as well

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
PREMIUM
PERMISSIONS LEVEL
Site Admin
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you