JJupin: How to work with Request participants field

All attempts to modify the Request participants Service Desk field with JJupin SIL scripting is failing with error "java.lang.ClassCastException: java.lang.String cannot be cast to java.util.Collection".

Example code:

JUser[] participants;
participants = addElement(participants, getUser("admin"));
#{Request participants} = participants;

Another attempt:

#{Request participants} = addElement(#{Request participants}, getUser("admin"));

And another:

#{Request participants} = addElement(#{Request participants}, "admin");

Am I doing something wrong, or is JJupin not capable of handling the Request participants field?

3 answers

1 accepted

Hi Thomas,

 

Could you please go to Custom Field Mappings and chage the Value factory to  User[] -> string[]? 

This should do the trick.

 

HTH,

Alex

Hi

Setting it to "User[] -> string[]" worked perfectly, thank you!

Anyway, how do you like version 4.0.0 so far? We are pretty proud of it smile ...

I haven't had a chance to use any of the new features yet, but it looks very good. I expect we'll be making use of the JQL support as well as the JIRA Agile and JIRA Service Desk integrations. Possibly the mail handlers too. I can say though that the UI improvements are nice smile

Hi,

give a try with string array participants:

string[] participants={};

participants = addElement(participants, getUser("admin"));
#{Request participants} = participants;

Hi

Thanks for the reply, but I get the exact same results with a string array (in fact that was what I tried in one of my first attempts).

For reference this is with JIRA Software 7.2.7, Service Desk 3.2.7 and JJupin 4.0.0

Hi Thomas,

I can't get this working when using JUser[] but using string[] instead works. Also, this may or may not be relevant to you but I noticed that if I am trying to request participants on any other transition than the create transition, then it works if I refer to the custom field directly rather than as #{..}.

In my case, I am requesting participants on a later transition and the string[] worked as soon as I reverted to using customfield_10408 = <value>

 

If you could share some thoughts on what could be stopping the JUSer[] from working, that'll be really great.

 

Thanks

Anupam

Hi Anupam

The accepted solution worked for me ("go to Custom Field Mappings and change the Value factory to  User[] -> string[]")

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published Jun 14, 2018 in Jira Service Desk

How the Telegram Integration for Jira helps Sergey's team take their support efficiency to the bank

...+ reading Fantasy). The same is true for him at the bank he works for: Efficiency is key when time literally equals money. Read on to learn how Sergey makes most of the time he has by...

503 views 3 5
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you