JIRA5.2.6 hangs on when importing data from JIRA 4.3.4


I'm trying to install a JIRA 5.2.6 platform using the data from JIRA 4.3.4. I've installed the latest standalone JIRA (5.2.6) and created an XML backup from exsting 4.3.4 JIRA server.

However, when trying to import the data it looks the JIRA hangs on when launching automatic upgrading task. Here is an extract from the atlassial-jira.log file. The custom field "Acceptance" (the field on which the upgrading process hangs on) is just a simple "Select list" custom field.

Any ideas how to fix this?

Thank in advance.

2 answers

1 accepted

are you trying to import the xml during the setup process?

if so could you just finish setup and import afterwards?

i think there were some changes made to customfields


you log lines...

Custom field searcher module: com.atlassian.jira.plugin.system.customfieldtypes:selectsearcher is invalid. Null being returned.
Custom field searcher module: com.atlassian.jira.plugin.system.customfieldtypes:radiosearcher is invalid. Null being returned.
Custom field searcher module: com.atlassian.jira.plugin.system.customfieldtypes:userpickersearcher is invalid. Null being returned.

maybe try upgrading to a 4.4 before you go on 5


Thank you for your answer. Actually, I've tried the both options. The result is the same - JIRA hags on when trying to upgrade the field "Acceptance".


The latest JIRA 4.4.x version is recommended for this process. The following resources in the JIRA 4.4.x documentation are good places to start for upgrading to the latest JIRA 4.4.x release

i suggest followin these instructions...i bet everything after 4.4 will be smooth to upgrade to 5.x

I've tried your proposal - indeed, it works well when the data is imported in JIRA 4.4.x at first. So, I performed the following steps and obtained JIRa 5.2.6 with actual data:

  • import JIRA 4.3.4 data to JIRA 4.4.x
  • create XML backup on JIRA 4.4.x
  • import newly create XML file to JIRA 5.2.6

Thank you.

You're welcome mate. Glad i could help. Enjoy the new release

This looks like its behaving as normal. Depending on the size of the data, this can take a long time. Have you tried to just let it run for a while?

The process have been working for 18 hours without any additional log records. It seems to be too much to migrate only a single custom field.

Suggest an answer

Log in or Join to answer
Community showcase
Alexey Matveev
Published Saturday in Jira

How to run Jira in a docker container

Everything below is tested on Ubuntu 17.10. I prefer to use Jira in a docker container because: 1. I can install Jira with a couple of commands. 2. I can start and stop Jira just by starting and s...

573 views 6 10
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot