JIRA startup failed, JIRA has been locked.

After our tech created a new first service desk to view as a customer (ANON). Jira crashed and will not start. I checked for a lock file with no success. I am unable to get Jira to start and the service stops.

I have tried restarting Jira, the jira service, stop and start from prog directory, shutdown and startup bundled jre (Error below extracted from doss box), Restarted the server.

I do not know how to do a clean restart or anything for JIRA. Jira has been running for over a year on windows server 2008 r2. I have recently added Agile and service desk. This is why he was creating a new test service desk.

This error is in the jre startup

******************************************

JIRA startup failed, JIRA has been locked.

******************************************

Jan 30, 2014 12:12:57 PM org.apache.catalina.valves.AccessLogValve open

SEVERE: Failed to open access log file [C:\Program Files\Atlassian\JIRA\logs\acc

ess_log.2014-01-30]

java.io.FileNotFoundException: C:\Program Files\Atlassian\JIRA\logs\access_log.2

014-01-30 (Access is denied)

3 answers

1 accepted

It looks like it was the memory issue after all. I opened up the permisions on the Jira directories, searched for lock files, I always have show hidden and system files on my servers.

I increased the Maximum memory limit for the JRE which did not fix it, i restarted the server no change, increased the Minimum memory alocation and got furthur. I now had the lock issue, I shut down the service and removed the lock file then restarted using the jre start batch file.

All working now...sorry I do not know what exactly fixed it or the minimum combination.

I hope that this helps someone else.

0 vote

The lock fine will be in JIRA Home folder and it is a hidden file. Delete it before restarting JIRA.

Btw, you have to fix the core problem or else the startup will fail again. Looks like there are some permission issues? Does your JIRA user has all the permissions needed in JIRA installation and home directories?

Thank you,

I am unable to find any lock files and have enabled view all hidden and system files, I have searched all of the jira directories for any ocurrance of lock.

I do not know how to resolve the core issue as I am unable to run jira (and new).

The JIRA user has admin access on the server directories as well as in jira

Another cause could be file owneship on jira directiories to a chown -R /var/atlassian/application-data/jira jira:jira and same for /opt/atlassian/jira

Suggest an answer

Log in or Join to answer
Community showcase
Sarah Schuster
Posted Jan 29, 2018 in Jira

What are common themes you've seen across successful & failed Jira Software implementations?

Hey everyone! My name is Sarah Schuster, and I'm a Customer Success Manager in Atlassian specializing in Jira Software Cloud. Over the next few weeks I will be posting discussion topics (8 total) to ...

3,198 views 13 19
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot