JIRA service is not installing

Windows Server 2008 R2. JIRA 5.1.4 was previously installed with the automated installer. I wanted to change its directory to the D: drive.

- Start > "Uninstall JIRA".

- Ran 5.2.6 installer, 'Custom' method, changed "C:" to "D:" in the two path options.

- JIRA did not run. Found that the service was still pointing to the C: location - clearly it had not been uninstalled, let alone re-installed. I executed "sc delete JIRAxxxx" at command line to remove it.

- Ran 5.2.6 installer again. 'Upgrade'. Still no service. Thought maybe 'Upgrade' doesn't re-register the service, so started from scratch.

- Start > "Uninstall JIRA".

- Rebooted machine.

- Ran 5.2.6 installer again (new install). Still no 'Atlassian JIRA' service.

It seems something is preventing the service from being installed again even when JIRA is installed from scratch. Any ideas?

2 answers

1 accepted

This widget could not be displayed.
Ahmad Danial Atlassian Team May 08, 2013

Hey there, My Kro.

Can I confirm that you have followed the steps from the official documentation as per the following:

Else if you are still facing problems with installing JIRA as a service, I would recommend you to lodge a support ticket in https://support.atlassian.com/ to get assistance on this problem that you are having. Hope this helps a bit.

Warm regards,

Danial

Thanks for the response, I tried the steps as follows:

D:\Program Files\Atlassian\JIRA\bin>echo %JAVA_HOME%
C:\Java\jre7
D:\Program Files\Atlassian\JIRA\bin>java -version
java version "1.7.0_21"
Java(TM) SE Runtime Environment (build 1.7.0_21-b11)
Java HotSpot(TM) 64-Bit Server VM (build 23.21-b01, mixed mode)
D:\Program Files\Atlassian\JIRA\bin>service.bat install JIRA
The JAVA_HOME environment variable is not defined correctly
This environment variable is needed to run this program
NB: JAVA_HOME should point to a JDK not a JRE

This helped me to discover the problem: another user had changed JAVA_HOME on the machine. I then ran into a different issue with 'Access denied' but that is unrelated so I will resolve this question. Thanks.

This widget could not be displayed.

Hey My Kro,

Check to see if JIRA service exists in services.msc console before installing again. You can uninstall a service by using

sc delete <servicename>

Hope that helps.

Gaurav

I have the opposite problem - the service does not exist in services.msc even after installing.

I know this is old, but I was unable to install the service until I deleted an old one left over from a previous install. 

Thank you!

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted Wednesday in New to Jira

Are you planning to trial, or are currently trialling Jira Software? - We want to talk to you!

Hello! I'm Rayen, a product manager at Atlassian. My team and I are working hard to improve the trial experience for Jira Software Cloud. We are interested in   talking to 20 people planning t...

292 views 5 0
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you