JIRA not synchronizing group membership from Crowd

As the description says, I am having a problem with JIRA not synchronizing group memberships for users.

We are using Crowd to pull the users from our Active Directory, and Crowd is properly reflecting that the user is a member of a specific group but JIRA does not.

I have checked in our instance of Confluence to see if it was communicating with Crowd properly and it is.

I'm stumped. Has anyone found a way to resolve this kind of issue?

1 answer

Hi, this is most likely a caching issue. Can you manually run the synchronization to check if this fixes the problem? Otherwise check how long the caching exists for in Crowd (default 1 hour).

Running a manual sync does not resolve the issue, sorry I should of placed that in the original message.

Are there any errors in the logs? You've said Confluence is communicating correctly with Crowd. Is JIRA?

I ran the built in log scanner and the scanner is stating that there is detecting a duplicate membership.

I will need to sit down with another admin and scour our logs in the morning it appears.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Sep 25, 2018 in Jira

Atlassian Research Workshop opportunity on Sep. 28th in Austin, TX

We're looking for participants for a workshop at Atlassian! We need Jira admins who have interesting custom workflows, issue views, or boards. Think you have a story to sha...

456 views 7 5
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you