JIRA and SVN Integration

Hi,

We are migrating from CTF to JIRA.

Our SVN uses the same credentials as CTF.

We have no idea about it.

However we are trying to integrate SVN with JIRA so that they use same credentials.

We followed the following steps:

1.Installed SVN Plugin

2.Add-ons -> SVN Repositories -> Add -> Entered info

We are getting the following error:

Now I would really like to know how the field in the page are linked or used.

Please let me know how to proceed.

Thank you,

Poornima.G

2 answers

0 vote

What versions of subversion are you using? Specifically, what's the svn server running as the service, and what client version do you have on the Jira server?

Hi Nic,

[root@CTF-TeamForge ~]# svnadmin --version

svnadmin, version 1.6.17 (r1126811)

compiled May 24 2011, 22:16:39

Copyright (C) 2000-2009 CollabNet.

Subversion is open source software, see http://subversion.apache.org/

This product includes software developed by CollabNet (http://www.Collab.Net/).

The following repository back-end (FS) modules are available:

* fs_base : Module for working with a Berkeley DB repository.

* fs_fs : Module for working with a plain file (FSFS) repository.

And my JIRA Download version is:

JIRA 6.2.4

SVN and JIRA are on two different servers.

Please help

Thanks,

Poornima

Ah, no, that's not what I asked. I asked what versions of *subversion* you are running on the two machines. You've given me one version - but is that the server or the Jira machine? And what version is the other machine running?

Hi Nic,

Subversion is installed in a linux machine and JIRA is installed on another Linux machine.

That's not answering the question. Let me break it down as much as I can.

What version of subversion is the subversion SERVER running as the service?

What version of subversion is the Jira Server running as the client?

Hi Nic,

I am new to this, I know that the Subversion Server is using the version 1.6.17 on subversion SERVER.

I am not sure if this would be helpful or not, but I have installed 0.10.14 Jira subversion plugin in Jira Server.

And the Jira Version I am using is: 6.2.4

Now I want to integrate Jira with Subversion server.

Assuming that I have freshly installed Jira and SVN Server on two different Linux machines, could you please help me in integrating Jira with SVN Server?

Thanks in advance,
Poornima

Ok, finally. I have a feeling that your version of the plugin doesn't work with old versions of Subversion.

The other option is that you've got the wrong credentials of course, but I'm not sure it's that.

Could you read the log file for Jira (have a look in Admin -> System Administration to find out where it is) and look for subversion related errors?

Nic is correct about the mismatch of plugin with the subversion server.

I would like to know which subversion plugin you are using and its version? That information is available from the admin/manage addons page. If it is the Subversion ALM plugin then contact the developer. If it is Jira Subversion plugin, I would try Subversion ALM.

Atlassian has been extremely slow fixing issues and only doing the bare minimum maintaining the Jira Subverson plugin. You should report the issue to Atlassian, but don't expect it to be fixed in a timely fashion.

Hi Norman,

My plugin information:

Installed add-on JIRA Subversion plugin (com.atlassian.jira.plugin.ext.subversion version 0.10.14)

JIRA Subversion plugin

Version: 0.10.14
Developer:${project.organization.name}
Add-on key:com.atlassian.jira.plugin.ext.subv

Any help

And am in a hurry as our tool for project management is expiring soon.

Thanks in advance,

Poornima

Yes, that's the Atlassian plugin. I'm pretty sure you're stuck - the libraries in that plugin are not compatible with your old version of Subversion.

Your options are a subversion upgrade, trying the ALM subversion plugin (it's good, but I have no idea if it's compatible with svn 1.6), or re-writing bits of the Atlassian plugin such that it uses compatible libraries and calls to subversion.

Hi Nic,

I have found the following error in the log file.

2014-04-30 12:13:05,804 http-bio-8443-exec-3 ERROR gpoornima 733x57001x2 18gstjo 115.115.69.250 /secure/AddSubversionRepository.jspa [plugin.ext.subversion.SubversionManagerImpl] Connection to Subversion repository https://ctf.mks.ch/svn/failed: org.tmatesoft.svn.core.SVNException: svn: E175002: PROPFIND of '/svn': 405 Method Not Allowed (https://ctf.mks.ch)

org.tmatesoft.svn.core.SVNException: svn: E175002: PROPFIND of '/svn': 405 Method Not Allowed (https://ctf.mks.ch)

at org.tmatesoft.svn.core.internal.wc.SVNErrorManager.error(SVNErrorManager.java:64)

at org.tmatesoft.svn.core.internal.wc.SVNErrorManager.error(SVNErrorManager.java:51)

at org.tmatesoft.svn.core.internal.io.dav.DAVUtil.findStartingProperties(DAVUtil.java:136)

at org.tmatesoft.svn.core.internal.io.dav.DAVConnection.fetchRepositoryUUID(DAVConnection.java:121)

at org.tmatesoft.svn.core.internal.io.dav.DAVRepository.testConnection(DAVRepository.java:103)

at com.atlassian.jira.plugin.ext.subversion.SubversionManagerImpl.activate(SubversionManagerImpl.java:249)

at com.atlassian.jira.plugin.ext.subversion.SubversionManagerImpl.setup(SubversionManagerImpl.java:84)

at com.atlassian.jira.plugin.ext.subversion.SubversionManagerImpl.<init>(SubversionManagerImpl.java:55)

Please help .

Thanks in advance,

Poornima

Ok, You are using the Atlassian version of the plugin. Your subversion 1.6 is a bit old now (ie it is not supported anymore)

http://subversion.apache.org/docs/release-notes/

So there are a few different things to try.

1) Upgrade to subversion 1.8 (maybe 1.7). Be aware this is not an easy task since everyone's repository and local copies needs to be upgraded as well as all the client tools.

or

2) Uninstall the plugin and install Subversion ALM and see what happens. I would tyr this first since it should be less painful route.

Er, that's not true, you don't have to point the plugin at a viewer. ALM is just as difficult to configure (in fact, they're both an absolute doddle), but it does do a lot more than the Atlassian one. Well worth evaluating it.

Hi,

I have tried Subversion ALM Plugin and still am getting the error:

I am still looking to make this work .

Any help is much appreciated.

Thanks,

Poornima

I still suspect a mismatch in what is supported here - i.e. the libraries in the plugins you've tried do not work with subversion 1.6 server.

However, I have a stronger feeling that you simply haven't given the plugins in Jira the correct account and/or server details.

@Nick, the Atlassian's plugin and ALM work with Subversion 1.6 as SVNKit guarantees the backward compatibility.

@poormina, Collabnet has several products and it seems you are confusing Teamforge with Edge. You are still providing a Temforge's url, and this will not work with any product. You need to provide a Subversion url (through Edge -> Apache). Otherwise, this will never work.

Ah, that's good to know, thanks! I've got an old client who are looking at upgrades and struggling with the Atlassian plugin, so I can tell them ALM supports their old svn install now.

Anyway, that proves it - Poornima is entering the wrong data - either the url, username or password are wrong. It can't connect.

Poornima is entering the wrong data - either the url, username or password are wrong. It can't connect.

Simply, click on the url used by Poormina: https://ctf.mks.ch/

It opens the initial page of the CTF demo. There are not any Subversion listening there (CTF is an application similar to JIRA), it is like you point the Subversion or ALM plugins to https://jira.atlassian.comor http://www.microsoft.com. As there is not a Subversion server behind the url, it is imposible that SVNKit works.

[plugin.ext.subversion.SubversionManagerImpl] Connection to Subversion repositoryhttps://ctf.mks.ch/svn/failed: org.tmatesoft.svn.core.SVNException: svn: E175002: PROPFIND of '/svn': 405 Method Not Allowed (https://ctf.mks.ch)

org.tmatesoft.svn.core.SVNException: svn: E175002: PROPFIND of '/svn': 405 Method Not Allowed (https://ctf.mks.ch)

You have to point the plugin to a valid Subversion server. Accordingly your logs, you are using the Teamforge server url instead.

Surely, Subversion ALM is a better option for you as it is easier to configure. Once you have registred your Subversion server, Subversion ALM will work while the Atlassian's JIRA Subversion plugin would require extra configuration to point the plugin to a Subversion web client (ViewVC or something similar).

Suggest an answer

Log in or Join to answer
Community showcase
Sarah Schuster
Posted Jan 29, 2018 in Jira

What are common themes you've seen across successful & failed Jira Software implementations?

Hey everyone! My name is Sarah Schuster, and I'm a Customer Success Manager in Atlassian specializing in Jira Software Cloud. Over the next few weeks I will be posting discussion topics (8 total) to ...

3,300 views 14 20
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot