JIRA and Forefront UAG

Hiya,

A customer is running JIRA behind Microsoft Forefront UAG and has requested my help in validating their install.

I now face a curious situation where accessing Admin -> Projects -> <some project> Roles will display the string "admin.project.role.none" instead of any roles when accessed through UAG, but will show rules just fine when accessed on the local machine through port 8080.

Does anyone have any ideas?

Thanks in advance,

Sune Mølgaard

1 answer

Additional info: Upon login, the following appears in the log file:

08-04-2013 14:32:25 com.sun.jersey.spi.container.servlet.WebComponent filterFormParameters
WARNING: A servlet POST request, to the URI http://a.b.c:8080/rest/gadget/1.0/login, contains form parameters in the request body but the request body has been consumed by the servlet or a servlet filter accessing the request parameters. Only resource methods using @FormParam will work as expected. Resource methods consuming the request body by other means will not work as expected.
(server address masked by me)

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Nov 27, 2018 in Portfolio for Jira

Introducing a new planning experience in Portfolio for Jira (Server/DC)

In the past, Portfolio for Jira required a high degree of detail–foresight that was unrealistic for many businesses to   have–in   order to produce a reliable long-term roadmap. We're tur...

2,723 views 17 21
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you