[JIRA] User authenticates successfully, but browser does not proceed to the Dashboard/ Issue Navigator

One of our JIRA users has encountered that once authenticated to JIRA, user cannot proceed to the dashboard or Issue Navigator. Once logged in, the browser seems to be waiting forever!

Once this user enters username and password to JIRA, we observed that authentication passed.

- atlassian-jira-security.log indicates that user has 'PASSED' authentication

- in JIRA's user sessions, a session has been created for the user with only one HTTP request

- under JIRA's users, user's log in count increments by one

- after this point, user is not taken to anythere. The browser is not freezed, but it is waiting for the JIRA server.

We also tried with 'os_destination' set to an issue, and issue navigator URLs instead of the dashboard. Results are the same.

We tried with separate browsers, from separate locations, and by clearing browser data. But none of these worked for this user. But when I tried to log in with my username and password on this user's workstation, login succeeded.

Only one user is currently having this problem. None of the other users reported a similar problem.

Has anyone encountered with similar incidents?

4 answers

This widget could not be displayed.

Hi Sameera,

Try to access this URL after the user is authenticated:

<JIRA Server Base URL>/secure/QuickSearch.jspa?searchString=%22+%22

That will clear of the issue navigator history. There is a possibility that the issue is due to complicated search string that cause JIRA to load a long time to return. If that is the case, the above URL should help.

Hope it helps.

Cheers,
Septa Cahyadiputra

This widget could not be displayed.

This might sound a bit obvious... but have you double-checked the access rights for the user in question? After all, it's a problem that only affects one user and you have already proven that it is not browser-related.

I experienced a similar problem myself just a week or two ago on a plugin-creator's OnDemand instance. I knew that I was logged in but nothing was happening. I would be looking at the Sustem Dashboard but nothing would happen when I clicked on any link. I would input (say) the direct link to an Issue and all that would display was the System Dashboard. Not quite "browser seems to be waiting forever" but it seemed to me that I was waiting forever.

What had happened was that my access rights had been nobbled. Once that was realized, things were fixed in a matter of moments.

Yes, I double checked access rights. Still user was unable to log in.

However, after a JIRA restart, user was able to log in. Now what we really need to find out is the root cause.

This widget could not be displayed.

i dont think this will resolve your issue but just for confirmation

check is there any error throwing by JavaScript by opening firebug in firefox.

There were no Javascript errors.

This widget could not be displayed.

UPDATE:

After a JIRA restart user was able to log in. Now what we really need to find out is the root cause.

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted Wednesday in New to Jira

Are you planning to trial, or are currently trialling Jira Software? - We want to talk to you!

Hello! I'm Rayen, a product manager at Atlassian. My team and I are working hard to improve the trial experience for Jira Software Cloud. We are interested in   talking to 20 people planning t...

83 views 1 0
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you