JIRA Stops working

HI All

I have a standalone version of JIRA.

Today morning I observed that the JIRA is not loading up. It is showing 404 Requested resource not available error.

What can be the cause?

I have checked there is nothing in the logs.

I have also tried doing the stop/start (JIRA as a service) and still the same.

I also observe that the Virtual machine (that hosts this JIRA) was restarted last night and thereafter the problem is appearing.

Rahul

3 answers

1 accepted

HI NIc....thanks for your comments. I have now resolved the issue, The problem was that we had two parallel jira installation on the same VM and when VM restarted it triggered both jira installations to start up. When i shut down the unwanted jira installation then the required jira loaded up.

Rahul

1 votes

Hmm. From that, I'd say your virtual machine is not configured to automatically restart Jira when it's rebooted.

You can check that by comparing the Jira log with the reboot time, although it may be that the Jira log has no entries for a while before reboot, if Jira was not being used at the time.

Check the OS settings for restart and get back to us if you're stuck

Hi NIc

From the logs I can see that after the reboot jira started automatically (all the startup logs are fine) and finally i get the message JIRA scheduler started.

I have also manually restarted the instance(stop start) but its the same.

I still cannot access the system not even via http://localhost from the VM itself.

I am getting this message.

HTTP Status 404 - /


type Status report

message /

description The requested resource (/) is not available.


Apache Tomcat/5.5.26

Ok, that's a useful thing to know. Without seeing the logs, it sounds like it's starting and running ok, but that it's not running where you expect it to. I've done this a few times myself - reconfigured Tomcat to present Jira somewhere else and completely forgotten to restart it to pick up the changes.

It's quite likely that it's running on something like http://localhost/jira or something, instead of being at the root of the server. It might also be blocked by something, so although it's running, you can't reach it.

Your Tomcat logs should show you more - look for catalina.out

Hi Rahul,

Before starting jira, check for ".jira-home.lock" in Jira home directory, delete if exists and start Jira. It's just a try as we are not sure about the issue.

Venkat

Suggest an answer

Log in or Join to answer
Community showcase
Sarah Schuster
Posted Jan 29, 2018 in Jira

What are common themes you've seen across successful & failed Jira Software implementations?

Hey everyone! My name is Sarah Schuster, and I'm a Customer Success Manager in Atlassian specializing in Jira Software Cloud. Over the next few weeks I will be posting discussion topics (8 total) to ...

2,754 views 11 18
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot