It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

JIRA QUEUE: Warning: Sending mail is disabled

I have upgraded my jria to jira 4.4.5. I have configured new smtp server. Verified a test email as well and then sent and email to a group all worked fine. But when I create a ticket emails are stuck in queue. In mail Queue as shown in image I can see a Warning: Sending mail is disabled

From where I can enable this?

Many thanks in advance.

Soh

4 answers

1 accepted

5 votes
Answer accepted

As a follow up to pjesi's post, in my SDK I added the systemPropertyVariables in the pom.xml as below and it worked:

<build>
<plugins>
<plugin>
<groupId>com.atlassian.maven.plugins</groupId>
<artifactId>maven-jira-plugin</artifactId>
<version>3.7.2</version>
<extensions>true</extensions>
<configuration>
<productVersion>${jira.version}</productVersion>
<productDataVersion>${jira.version}</productDataVersion>
<systemPropertyVariables>
<atlassian.mail.senddisabled>false</atlassian.mail.senddisabled>
</systemPropertyVariables>
</configuration>
</plugin>

</plugins>

</build>

The problem is that this does not work with atlas-run-standalone

It was disabled from

JAVA_OPTS="-Datlassian.mail.senddisabled=true

how did you enable it?

You can run it as atlas-run-standalone --product jira --jvmargs '-Datlassian.mail.senddisabled=false'

the above comment (atlas-run-standalone --product jira --jvmargs '-Datlassian.mail.senddisabled=false') worked perfectly for me, thank you

Tam Tran Atlassian Team Sep 24, 2015

@Andrew Zakordonets's comment should be an accepted answer. Thank you!

Patrick Cartier Community Leader Oct 04, 2019

If I run this, all I have is Jira Core, anyway to run this and get Jira Software?

Just an update for anyone new coming to this question, in the latest JIRA there is way to disable outgoing mail from the UI.

Navigate to the outgoing mail configuration panel, and ensure that outgoing mail is enabled.

I have answered it already. In my case I configured a second test server for jira I disabled emails by calling send.disabled=true in JAVA_OPTS so people shouldn't get emails from test server. Sam

I was using the SDK and it didn't work there. But I managed to get it to work by adding as <systemPropertyVariables> in pom.xml

Hi.

The solution above works running the command atlas-debug? I put the following code

<systemPropertyVariables>
<atlassian.mail.senddisabled>false</atlassian.mail.senddisabled>
</systemPropertyVariables>

in the pom.xml (the pom.xml of the plugin that I'm developing) but when I go to the Administration > Outgoing Mail, a message is displayed in the top of the page.

Outgoing mail was disabled with the -Datlassian.mail.senddisabled=true JVM argument before JIRA was started. JIRA cannot send email until you remove the JVM argument and restart JIRA

Anyone has a solutions for this? I'm using the sdk 6.2.14, with jira 7.2.2.

Thanks

I found a way to do that: execute the command

atlas-debug --jvmargs -Datlassian.mail.senddisabled=false

 Thanks

Suggest an answer

Log in or Sign up to answer
Community showcase
Published in Jira

The add-in you’ve been waiting for: Jira Cloud for Excel 🙌

Introducing Jira Cloud for Excel Here at the product integrations team at Atlassian, we are thrilled to announce the new Jira Cloud for Excel add-in! This add-in lets you export Jira data directly ...

950 views 8 25
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you