JIRA Latest fails to restart after JIRA Agile and Capture installation

I installed JIRA 6.1.3 and it worked smoothly. Integrated with Crowd and everything. Even restarted the server without any problems. However, today, after installing Agile and Capture plugins server doesn't restart properly, it locks down with log file full of plugin errors. This specific problem has happened since Thursday, making me install JIRA for 4 times already. On Thursday, finally I just installed it fresh, and then shut down the server (an AWS instance). Today I restarted the instance, JIRA opened as normal, without any plugins installed. I installed Agile and Capture again, plus Balsamiq Mockup addon. Plugin system reported successful installation, indexed plugins as well. But after service restart, what had happened before happened again: tons of plugin errors and locked down JIRA. Any idea how this can be solved? I can provide server access if needed, since all it has is Atlassian tools installed.

5 answers

1 accepted

Hey all who wonder how this issue was resolved back in the day. Following is the my final response to support specialist Joe Wai Tye:

Yea, it was as you guessed: resources.

I added timeout settings to JIRA startup and server started without problems [here I mean I increased max startup timeout duration]. All working 100%. Til now, I have always installed and maintained Atlassian tools on dedicated physical servers with 8G Ram. I never realized that these tools are so heavy that they don't startup on Paravirtual Machine with 4G Ram. Had to start each application (JIRA, Confluence and Stash) in succession for it to work.

Thanks Joe for support, you been of great help.

So, long story short: its about RAM mainly. Either increase it, or increase max timeout for Java app.

Which errors are you getting in your logfile?

Best regards,

Peter

Heya Shahriyar,

When you restart the server, is all the Atlassian Tools also all restarted and startup at the same time? Because, it will take a quite of resource when starting JIRA with its plugin and it have to share with other software.

About the plugin error itself, is there an error where it told you that it is not yet enabled so JIRA is locked, or there is a connection timeout? I would like to suggest you to increase the memory that could be use for your JIRA instance, you may follow this documentation on how to do it:

I might jump to quickly on my suggestion, but hope this could help you.

Best Regards, Julian.

How do I delete this question?

HI shahriyar,

How you resolved this issue. I installed agile on JIRA and after restart JIRA instance doesn't started. Appriciate if you could mention how you resolve it.

Regards,

Heshan

Suggest an answer

Log in or Join to answer
Community showcase
Sarah Schuster
Posted Jan 29, 2018 in Jira

What are common themes you've seen across successful & failed Jira Software implementations?

Hey everyone! My name is Sarah Schuster, and I'm a Customer Success Manager in Atlassian specializing in Jira Software Cloud. Over the next few weeks I will be posting discussion topics (8 total) to ...

2,826 views 12 18
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot