JIRA HTML-resources are not loaded with Proxy

I followed the directions on this page: https://confluence.atlassian.com/kb/proxying-atlassian-server-applications-with-apache-http-server-mod_proxy_http-806032611.html

 

The original URL with IP:PORT is still working fine, but the HTML-resources are not loaded in my Proxy-URL (eg. jira.domain.com). When I access these HTML-resources directly, I do see the contents of these files.

The problem might be the relative URLs inside the HTML-source:

<link type="text/css" rel="stylesheet" href="/s/{...}/batch.css" media="all">

 

My Apache2-conf is as follows:

<VirtualHost *:80>
    ServerName jira.company.com

    ProxyRequests Off
    ProxyVia Off

    <Proxy *>
         Require all granted
    </Proxy>

    ProxyPass           / http://localhost:8100/
    ProxyPassReverse    / http://localhost:8100/
</VirtualHost>

I am using port 8100 because the default port was already in use.

1 answer

Did you make the changes to the server.xml described in step 3 and bounce JIRA? That's a really important step. Skip step 2 in your case.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Oct 16, 2018 in Jira

Looking for anyone who made the switch to Data Center

The Jira Marketing team is putting together an ebook on migrating to Data Center. We're looking for pro tips on how you staffed your project team and organized your Proof of Concept. Share yo...

1,385 views 17 10
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you