JIRA_HOME dir has weird permissions after upgrade from 4.4.3 to 5.0.7

After I upgraded my Jira instance from v4.4.3 to v5.0.7 I found that the permissions on the $JIRA_HOME directory had changed to something I'd never seen before:

[13:20:40 lhawkes@]$ ls -lA /var/atlassian/jira_v422/data/
total 0
?--------- ? ? ? ?            ? avatars
?--------- ? ? ? ?            ? attachments

The $JIRA_HOME directory is owned by user jiraapp. If I try the same command as user jiraapp I get a different result:

[13:27:14 lhawkes]$ sudo -u jiraapp ls -lA /var/atlassian/jira_v422/data/
total 8
drwx------ 21 jiraapp jiraapp 4096 Aug 21 16:29 attachments
drwx------  2 jiraapp jiraapp 4096 Jun 12 17:51 avatars

In the specific case, the parent folder (/var/atlassian/jira_v422/data/) gives read permissions to all users

[13:31:49 lhawkes@usindjira01t:jira_v422]$  ls -lA /var/atlassian/jira_v422/
total 76K
drwxr--r-- 4 jiraapp jiraapp 4.0K Aug 29 19:35 caches/
drwxr--r-- 4 jiraapp jiraapp 4.0K Nov 14  2011 data/

Jira is hosted on a Red Hat Linux system. I'm familiar with unix permissions and the standard behavior when one doesn't have permissions for a specific directory. I've never seen this before. So far I haven't seen any problems that I can tie directly to this behavior, but it is odd.


Note: I realize that the directory is called jira_v422 and I'm talking about an upgrade from 4.4.3 to 5.0.7. The name is a relic from my original installation of Jira v4.2.2.

2 answers

0 vote

Oooh, pretty. The ?------- usually means "I, the operating system, either can't read the permissions, or I can, but I'm not going to tell you for some reason".

Last time I saw that, it was because I'd created the file system on another computer, with VMS, and later pulled the drive and whacked it in a Linux box. I was able to reset it with a simple "chmod" as root, and as soon as I had, all the files worked fine again (And still are). I don't know how you'd do it without swapping OSs though!

Hmmm... maybe that's it. I have seen similar patterns when viewing Windows directories through cygwin. When I did the upgrade I ran atlassian-jira-5.0.7-x64.bin from my home directory, which is on a remote filesystem that's mounted to my Jira server.

I suspect that could be a bit like my "did stuff to the disk with another operating system", but I'm not going to pretend I'm any form of Unix expert and claim that's the explanation!

Anyway, if you've changed permissions, could you check what you see with three different users? The owner you want to use, root, and some other user that isn't anything to do with Jira. I'm afraid I'm completely stuck (I use Linux a heck of a lot, but this is quite deep into "obscure stuff most people won't run into" territory), but I suspect someone here with more Unix experience would ask that question.

Addendum: I have tried changing the permissions of the affected files and I see the same behavior. The files' permissions change, but even if they are 777 (rwxrwxrwx), the files are still shown as having permissions ?--------- ? ? ? ?

This is the bit that's the most confusing to me, no pun intended.

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published yesterday in Jira

5 ways you can make the most of Jira Software and Bitbucket Cloud

As part of the Bitbucket product team I'm always interested in better understanding what kind of impact the use of our tools have on the way you work. In a recent study we conducted of software devel...

45 views 0 4
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you