JIRA Backup Error Edited

Hello,

Trying to migrate on new Jira instance.

  • v6.4.12#64027-sha1:e3691cc)
  • Oracle DB

When I perfom backup from JIRA (from Backup System)

I always get the error:

An exception occurred backing up: org.ofbiz.core.util.GeneralRuntimeException: Error creating GenericValue (SQL Exception while getting value: (Invalid column type: getBLOB not implemented for class oracle.jdbc.driver.T4CLongRawAccessor))

 Found the same error here: https://confluence.atlassian.com/jirakb/invalid-column-type-getblob-not-implemented-for-class-oracle-jdbc-driver-t4clongrawaccessor-during-backup-process-854131615.html

Made this:

desc propertydata
Name          Null     Type       
------------- -------- ---------- 
ID            NOT NULL NUMBER(18) 
PROPERTYVALUE          BLOB       

But this doesn't help, still get the error. 

I've also tried Integrity Checker, all fine.

Cant find another way to migrate.

Any ideas? 

 

Caused by: org.ofbiz.core.entity.GenericDataSourceException: SQL Exception while getting value:  (Invalid column type: getBLOB not implemented for class oracle.jdbc.driver.T4CLongRawAccessor)
	at org.ofbiz.core.entity.jdbc.SqlJdbcUtil.getValue(SqlJdbcUtil.java:728)
	at org.ofbiz.core.entity.EntityListIterator.currentGenericValue(EntityListIterator.java:169)
	at org.ofbiz.core.entity.EntityListIterator.next(EntityListIterator.java:246)
	... 199 more
Caused by: java.sql.SQLException: Invalid column type: getBLOB not implemented for class oracle.jdbc.driver.T4CLongRawAccessor
	at oracle.jdbc.driver.Accessor.getBLOB(Accessor.java:1270)
	at oracle.jdbc.driver.OracleResultSetImpl.getBLOB(OracleResultSetImpl.java:1623)
	at oracle.jdbc.driver.OracleResultSetImpl.getBlob(OracleResultSetImpl.java:585)
	at org.apache.commons.dbcp.DelegatingResultSet.getBlob(DelegatingResultSet.java:550)
	at org.apache.commons.dbcp.DelegatingResultSet.getBlob(DelegatingResultSet.java:550)
	at org.ofbiz.core.entity.jdbc.SqlJdbcUtil.getValue(SqlJdbcUtil.java:647)
	... 201 more

 

1 answer

0 votes

Hi Artem,

I believe you may be running into the bug reported JRASERVER-47267.  Please see the ticket and the steps to resolution:

  1. Identify the latest XML backup from the $JIRA_HOME/export directory
  2. Create a new user as per the Connecting JIRA to Oracle guide
  3. Install a new JIRA 7.0.0 instance and connect it to the new Oracle user
  4. Import the XML backup

Cheers,

Branden

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Sep 18, 2018 in Jira

What modern development practices are at the heart of how your team delivers software?

Hey Community mates! Claire here from the Software Product Marketing team. We all know software development changes rapidly, and it's often tough to keep up. But from our research, we've found the h...

23,101 views 2 7
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you