Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

JIRA 7.2.5 failed to start up

Greetings

On my test bed (windows 7 - 64 bit)

I have JDK 1.8.0_111

MySQL 5.6.33

and installed JIRA 7.2.5  (using atlassian-jira-software-7.2.5-x64.exe).

it won't start up,

this is what I see in commons-daemon.2016-11-23.log:

[2016-11-23 12:05:12] [info]  [10096] Run service finished.

[2016-11-23 12:05:12] [info]  [10096] Commons Daemon procrun finished

[2016-11-23 12:46:26] [info]  [10900] Commons Daemon procrun (1.0.15.0 64-bit) started

[2016-11-23 12:46:26] [info]  [10900] Running 'JIRASoftware231116110535' Service...

[2016-11-23 12:46:26] [info]  [13276] Starting service...

[2016-11-23 12:46:26] [error] [13276] %1 is not a valid Win32 application.

[2016-11-23 12:46:26] [error] [13276] Failed creating java C:\Progra~2\Java\jre1.8.0_111\\bin\client\jvm.dll

[2016-11-23 12:46:26] [error] [13276] %1 is not a valid Win32 application.

[2016-11-23 12:46:26] [error] [13276] ServiceStart returned 1

[2016-11-23 12:46:26] [error] [13276] %1 is not a valid Win32 application.

[2016-11-23 12:46:26] [info]  [10900] Run service finished.

[2016-11-23 12:46:26] [info]  [10900] Commons Daemon procrun finished

 

any suggestion of an easy fix  before I raise a case ?

 

thanks & regards

 

1 answer

Dave from Atlassian support suggested this Link (Thanks):

this KB for more details   (https://confluence.atlassian.com/jirakb/jira-service-fails-to-start-in-windows-is-not-a-valid-win32-application-313463797.html)

Problem fixed by removing JRE_HOME environment viraiable, then starting new command prompt, then removing the service (using service.bat remove) then re-adding it back (service.bat install).

regards

 

Thanks, was getting frustrated after 2 days of trying out different ways to make this work. The above worked fine for now. 

Suggest an answer

Log in or Sign up to answer
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you