JIRA 5.2 "Assigned to me" doesn't return any records

Issue Navigator - Clicking on "Assigned to me" doesn't return any records even though there are matching records for the current user with resolutions as 'Unresolved'

2 answers

1 accepted

Try this search:

assignee = currentUser() AND resolution = Unresolved

I have tried this and it doesn't return any data!

But this returns the correct data:

assignee = currentUser() AND resolution = "\"Unresolved\""

What is the problem??

Go to admin->issue->resolution:

Delete Unresolved if any.

Hi ck,

But why??

As I try to delete it says:


Delete Resolution: Unresolved

Confirm that you want to delete this resolution, and specify what is to be done with the issues currently attached to it.

There are currently 167 matching issues, that must be changed to another resolution.

New resolution for matching issues

You really do NOT want a Resolution called "unresolved".

The reason is simple - Jira considers the Resolution field to be the "open or closed" flag. If the field contains any data, the issue is "closed". It does not care if the data says "unresolved", "open", "penguin", "closed", "anvil" - the issue is closed because the field is set.

This makes resolutions with names like "unresolved" or "not done yet" or "open" an absolute nightmare for the humans because they see "unresolved" whereas Jira sees the issue as "resolved"

In other words, delete "unresolved" now. It's making your data complete nonsense. (167 issues is a minor change, you don't need script runners or anything complex, just delete it)

Nic,

I want to delete it but what should I select for 'New resolution for matching'???

Ah, I see. Sorry.

You can't select the "empty" option when doing this. The assumption is that resolved issues would stay resolved and you're only removing the resolution because it needs changing to another.

You'll need to bulk-edit the issues to remove the resolution before deleting it. 167 is only a small set though.

Try this:

Create new resolution say "TEST", delete "unresolved" by mapping it to "TEST".

After that searching "TEST" resolution in filter. re-opened all 167 issues by bulk operations.

Again delete "TEST" resolution.

Hopes it helps you

Er, @ck - you know that all that does is rename the problem from "unresolved" to "TEST"? That's not going to fix any of CV's problems, it's just an extra, unneccessary step.

1 votes

Also try a debugging test by specifying the user directly. If you were logged in as me for example, then try "assignee = currentUser()" and "assignee = nic", and a third test of "assignee = nic" when logged in as someone else.

The numbers you get out of those might tell you more about the problem.

how do I run debug test?

Sorry, I was not clear. I only said "debug", because that's what you're doing by running the searches and gathering more information.

Run the three searches I defined, and tell us what the answers are (how many issues each one returns)

Suggest an answer

Log in or Join to answer
Community showcase
Sarah Schuster
Posted Jan 29, 2018 in Jira

What are common themes you've seen across successful & failed Jira Software implementations?

Hey everyone! My name is Sarah Schuster, and I'm a Customer Success Manager in Atlassian specializing in Jira Software Cloud. Over the next few weeks I will be posting discussion topics (8 total) to ...

3,128 views 13 19
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot