JEP 4.3.6 custom field does not work with localized settings.

I just tried this plugin with latest JIRA 6.1.7 with system language and UI set to S-Chinese. It seems that it doesn't work with localized settings. I follow the video:http://www.youtube.com/watch?v=gn9-RDrSkrw and created a custom field: time between open and resolved (or name the custom field with S-Chinese string). I just cant go further more to define its status range. after saving it value from open to resolved then I turned back to its summary. I just shows that no status range is defined.

1 answer

1 accepted

1 vote
Accepted answer

Hi Pupie,

I have created an issue about this. You can see and follow it via link https://bitbucket.org/tuncaysenturk/jira-enhancer-plugin/issue/55/jep-436-custom-field-does-not-work-with

Could you please provide me more info and attach screenshots in order to see where the problem is?

I am waiting for your response to solve the problem as soon as possible.

Regards

Tuncay Senturk

Hi, Please refer below screenshots:

1. The system language is set to SChinese as below.

2. I logged in to system as Admin and created a custom field then apply it to a default screen.

3. Then try to config its status range as below

4. Select value from the list and click save button. The page reloads but stay on it.

it will not return to parent page as it is shown in step3.

5. I have to navigate to the JIRA issue tab and goto its summary again to check whether the change is saved. But nothing had been changed.

I also noticed that alot of strings from JEP can not be translated by IPT(In Product Translation) Addons such as the "Reopening History" and "Stateoscop" tab added to issues summary page and the time value unit.

I can't add attachments to the issue you created since server always return 403 error when trying to attach file to that issue. I also confirm that the control "Amount time till resolution"works with localized settings.

(atlassian-jira.log)

Hi,

I just reproduced this issue on my laptop with brand new installation of JIRA 6.1.7.

I just install mysql 5.6.16 on Win7 x64 Ultimate English with language locate/code page/format switch to SChinese/PRC. then I install JIRA and SChinese language pack, Change jira language to SChinese, Download and install JEP to configure as screenshots I provided above.

Hi Pupie,

I have reproduced and fixed the localisation problem. In a few days version 4.3.7 will be released.

Thanks for your help

Regards

Tuncay Senturk

Hi Tuncay,

I just tried 4.3.7 on JIRA 6.1.7 and the old issue is gone.

but there are still some strings not translatable . such as status string and the time unit on the stateoscope page.

I also tried the custom field using :time amont till resolution" and there is no way to translate the time unit. Please refer the screenshot.

I think this could be a localization enhancement CR.

Stateoscope page:

Hi Pupie,

Thanks for your feedback. I have missed those fields and I have just created an issue about this. Please watch the issue.

Thanks

Tuncay Senturk

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Nov 27, 2018 in Portfolio for Jira

Introducing a new planning experience in Portfolio for Jira (Server/DC)

In the past, Portfolio for Jira required a high degree of detail–foresight that was unrealistic for many businesses to   have–in   order to produce a reliable long-term roadmap. We're tur...

2,789 views 18 22
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you