Issues with Boards and addedAfterSprintStart function

Hi there

when clicking the added after sprint start button I get this in my issue filter:

Screen Shot 2016-03-09 at 11.50.24.png

Also we have seen this stacktrace:

 

My guess is, that this is related.

On the addon page all looks fine, also tried reindexing but did not help at all.


Best regards

Benjamin

24 answers

This widget could not be displayed.

What version of JIRA and JIRA Agile is this on? We are trying to reproduce this issue for you.

This widget could not be displayed.

it is on JIRA v6.4.7#64022-sha1:4cb2968 and Agile 6.7.11

This widget could not be displayed.

Hi Benjamin, we are having trouble reproducing this with the versions you have provided. What version of ScriptRunner do you have? 

Did you upgrade anything without restarting? Could you restart JIRA to see if this fixes the issue.

This widget could not be displayed.

HI Adam

Restart did not solve the issue. I was also able to reproduce on our testing environment.

 

Our full setup:

JIRA v6.4.7#64022-sha1:4cb2968

Adaptavist ScriptRunner for JIRA 4.1.3.9

Agile Poker for JIRA Plugin 2.0.6 (Disabled)

AM Utils 1.3.5

Atlassian Hipchat Integration Plugin 7.4.1

Atlassian Hipchat Integration Plugin Core 7.4.1

Atlassian JIRA - Plugins - Healthcheck Plugin 1.1.6

Atlassian Universal Plugin Manager Plugin 2.20.6

Bitbucket Importer Plugin for JIM 1.0.15

BizDock JIRA plugin 1.0.0

HipChat for JIRA 7.4.1 (Disabled)

Issue Templates for JIRA (Gold Edition) 4.6.1.1

JIRA Agile 6.7.11

JIRA Calendar Plugin 2.1.11

JIRA Charting Plugin 1.33

JIRA GitHub Issue Importer 2.0.10

JIRA iCalendar Plugin 1.4.6

jira-importers-plugin 7.1.8

JIRA Suite Utilities 1.4.10

JIRA Toolkit Plugin 0.35.11

JIRA Traffic-Light CustomField 1.6

Jolokia Agent for Atlassian 0.2

Redmine Importers Plugin for JIM 2.1.4 (Disabled)

Support Healthcheck Plugin 2.0.6

Support Tools Plugin 3.7.22

 

I hope this helps.

This widget could not be displayed.

Could you try disabling the other plugins on your test instance then reinstall JIRA Agile first and then reinstall ScriptRunner last to see if that has any effect to rule out possible interactions.

What is your "Java Version" from System Info? I tried on different Java versions but could not reproduce this.

Do you see any messages in the logs when installing ScriptRunner like: "This is JIRA Agile prior to the most recent supported version, functions won't work" or any exceptions in the logs?

This widget could not be displayed.

java version "1.7.0_55"

With all other plugins disabled it did not work either.

No error nor warn messages during reinstall. Reindexed and restarted.

The only suspicious log entries would be those:

2016-03-10 13:36:13,377 main INFO      [atlassian.plugin.manager.DefaultPluginManager] Returned module for key 'com.pyxis.greenhopper.jira:greenhopper-agile-shortcut' was null. Not enabling.
2016-03-10 13:36:13,377 main INFO      [atlassian.plugin.manager.DefaultPluginManager] Returned module for key 'com.pyxis.greenhopper.jira:greenhopper-taskboard-shortcut' was null. Not enabling.
2016-03-10 13:36:13,378 main INFO      [atlassian.plugin.manager.DefaultPluginManager] Returned module for key 'com.pyxis.greenhopper.jira:greenhopper-chartboard-shortcut' was null. Not enabling.
2016-03-10 13:36:13,378 main INFO      [atlassian.plugin.manager.DefaultPluginManager] Returned module for key 'com.pyxis.greenhopper.jira:greenhopper-releasedboard-shortcut' was null. Not enabling.
2016-03-10 13:36:13,378 main INFO      [atlassian.plugin.manager.DefaultPluginManager] Returned module for key 'com.pyxis.greenhopper.jira:greenhopper-boardsearch-shortcut' was null. Not enabling.
2016-03-10 13:36:13,378 main INFO      [atlassian.plugin.manager.DefaultPluginManager] Returned module for key 'com.pyxis.greenhopper.jira:greenhopper-nextcolumn-shortcut' was null. Not enabling.
2016-03-10 13:36:13,378 main INFO      [atlassian.plugin.manager.DefaultPluginManager] Returned module for key 'com.pyxis.greenhopper.jira:greenhopper-prevcolumn-shortcut' was null. Not enabling.
2016-03-10 13:36:13,379 main INFO      [atlassian.plugin.manager.DefaultPluginManager] Returned module for key 'com.pyxis.greenhopper.jira:greenhopper-toggledetailview-shortcut' was null. Not enabling.
2016-03-10 13:36:13,379 main INFO      [atlassian.plugin.manager.DefaultPluginManager] Returned module for key 'com.pyxis.greenhopper.jira:greenhopper-priority-shortcut' was null. Not enabling.
2016-03-10 13:36:13,379 main INFO      [atlassian.plugin.manager.DefaultPluginManager] Returned module for key 'com.pyxis.greenhopper.jira:greenhopper-delete-shortcut' was null. Not enabling.

But all 309 agile modules are enabled.

 

Otherwise nothing and still the same errors.

This widget could not be displayed.

Cleaning plugin cache did not help.

This widget could not be displayed.
This widget could not be displayed.

Yes I do

This widget could not be displayed.

Has anything changed recently? Did you get this after upgrading JIRA agile and did it ever work for you? It looks like some of the JIRA Agile plugin is not being started correctly for some reason. Have you noticed any problems when using the JIRA Agile plugin features?

This widget could not be displayed.

We have upgraded agile when 6.7.11 was released in December. We did not experience any issues then and have not seen any errors. Now last week we bought and installed Script Runner and it never worked.

This widget could not be displayed.

Would you be able to run the following code in the script console and put the output and any logs after running here please to help us narrow down the problem:

import com.atlassian.plugin.Plugin;
import com.atlassian.plugin.PluginAccessor;
import com.atlassian.sal.api.component.ComponentLocator;
Class.forName("com.atlassian.jira.component.ComponentAccessor");
PluginAccessor pluginAccessor = ComponentLocator.getComponent(PluginAccessor.class);
Plugin plugin = pluginAccessor.getPlugin("com.pyxis.greenhopper.jira");
This widget could not be displayed.

Result is: com.pyxis.greenhopper.JIRA

and no log output at all and nothing in the logs files either.

 

I also did the integrity check which passed.

This widget could not be displayed.

Hi Benjamin,

The suspicious log entries tend to suggest combined with the fact all 309 of your modules are still enabled suggests you may have 10 or so corrupt modules.

I see that you already disabled and then enabled JIRA Agile and that you cleaned up your plugin cache.

This AA articles mentions possible corrupted JIRA Agile modules after an upgrade and has steps you may want to take on your staging instance (essentially uninstall and then install JIRA Agile).

It's hard to diagnose this as a ScriptRunner problem when the only log entries refer to JIRA Agile.

Have you raised an issue on JAC for JIRA Agile (key JSW) as it seems you might have a problem there?

This widget could not be displayed.

Hi Mark

I have uninstalled and installed Agile and it did not solve the issue. So I agree, it looks like an agile issue. Therefore I opened https://answers.atlassian.com/questions/37544653 in hope to get help.

Once that is solved and I still have an issue with the Script Runner functions I will update the question here.

This widget could not be displayed.

Hi Mark

I opened a JSW ticket and a support request with Atlassian. There was nothing found.
What can be told is, that once ScriptRunner is disabled, everything works fine. As soon as it is on, we get errors on issue search and all functions with sprints and boards are not working. So it does look like an issue of ScriptRunner. What can I provide to help solving this issue?

 

Best regards 

This widget could not be displayed.

Hi Mark

I tried figure out what is happening with Atlassian support. We did not succeed, so I need help from you guys again. How can I get the information where the error comes from, what query is done that causes the error?

Best regards

Benjamin

This widget could not be displayed.

I can see the error exists also for others:

Error on Added after sprint start flag Version: 3.0.16.

This widget could not be displayed.

What version of the plugin are you using?

After installing/uninstalling JIRA Agile when ScriptRunner is installed, JIRA can get into a pathological state, where you need to restart it. Have you restarted?

This widget could not be displayed.

All versions are mentioned above. Here again:

Our full setup:

JIRA v6.4.7#64022-sha1:4cb2968

Adaptavist ScriptRunner for JIRA 4.1.3.9

Agile Poker for JIRA Plugin 2.0.6 (Disabled)

AM Utils 1.3.5

Atlassian Hipchat Integration Plugin 7.4.1

Atlassian Hipchat Integration Plugin Core 7.4.1

Atlassian JIRA - Plugins - Healthcheck Plugin 1.1.6

Atlassian Universal Plugin Manager Plugin 2.20.6

Bitbucket Importer Plugin for JIM 1.0.15

BizDock JIRA plugin 1.0.0

HipChat for JIRA 7.4.1 (Disabled)

Issue Templates for JIRA (Gold Edition) 4.6.1.1

JIRA Agile 6.7.11

JIRA Calendar Plugin 2.1.11

JIRA Charting Plugin 1.33

JIRA GitHub Issue Importer 2.0.10

JIRA iCalendar Plugin 1.4.6

jira-importers-plugin 7.1.8

JIRA Suite Utilities 1.4.10

JIRA Toolkit Plugin 0.35.11

JIRA Traffic-Light CustomField 1.6

Jolokia Agent for Atlassian 0.2

Redmine Importers Plugin for JIM 2.1.4 (Disabled)

Support Healthcheck Plugin 2.0.6

Support Tools Plugin 3.7.22


I have uninstalled and reinstalled and restarted several times. No luck.

This widget could not be displayed.

Sorry, I appreciate you might have said this before, but I need to double-check, also 3.0.16 is mentioned above.

Did you already have a support ticket for this? If not can you create one at productsupport.adaptavist.com/servicedesk/customer/portal/2.

In addition, can you first run the following in the script console:

import org.apache.log4j.Level
import org.apache.log4j.Logger

Logger.getLogger("com.atlassian.ozymandias").setLevel(Level.DEBUG)

And then reproduce the issue, then attach your logs to the ticket.

This widget could not be displayed.

There is no log output at all in the Atlassian logs when I run this script.

This widget could not be displayed.

This appears to be a bug in 4.1.3.9, and should be fixed in 4.1.3.10.

This widget could not be displayed.

First tests show that it is fixed in 4.1.3.10

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted an hour ago in Jira

Atlassian Research Workshop opportunity on Sep. 28th in Austin, TX

We're looking for participants for a workshop at Atlassian! We need Jira admins who have interesting custom workflows, issue views, or boards. Think you have a story to sha...

9 views 0 0
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you