Issue workflow status different in query search to status displayed within the issue

So i have a custom worklow, which is working fine.

When you click on an issue type it displays the status of the workflow it is in, whcih is correct.

I then run a query to show all the issue types which use this custom workflow. The results display all the issues, but the status of these issues is incorrect. For example it says the issues is still in 'Open' when in fact it is at the next stage along.

I have only come across this this mornig when i moved the issue to the next stage. I have re-run the query, instead of using teh saved query and it doesnt change.

Any ideas?

Ben

7 answers

This widget could not be displayed.

Ramiro has a valid point, but this may be shown also by an inconsistency in the db. Try to validate first the instance ....

You should check for errors in the logs ...

This widget could not be displayed.
Henning Tietgens Community Champion Mar 24, 2013

Hi Ben,

this is the typical behaviour for an index error. Something in your workflow has edited the issue in the wrong moment and this change was not indexed.

To fix this, you can install the Script Runner plugin and run the built-in script to reindex a filter result. Out of the it's only possible to edit the issue again or to run a complete reindex (which makes your JIRA instance inaccessible for that time).

You should investigate which changes in your workflow may cause this error. Maybe you changed something or installed a new plugin?

Henning

This widget could not be displayed.

Hi Ben, this could be a index problem. Have you already tried reindexing the Jira instance?

Restarting the server is the worst solution always (ugliest), but it's funny how it resolves many things. Take that as the last option and check Radu's answer, the error could be in the DB.

Hi Ramiro, Yes I have tried re-indexing, this has not worked. Thanks

I have tried re-indexing a few times today, bu this is not working.

I will have a look at the logs, as restarting the box is definatley on the bottom of the list.
This widget could not be displayed.

You probably need to re-index JIRA in order to solve this. To re-index JIRA follow the steps:

  1. Select "Administration" from the upper right corner
  2. Select "Advanced" from the "System" menu (enter your password if asked)
  3. On the (first) Indexing tab, click the re-index option which is most appropriate
  4. Click the "Re-Index" button

When finished you searches should work fine!

hope this helps,

Jacques.

This widget could not be displayed.

Hi Ben,

We have run into the exact same issue. Did you reach a resolution?

This widget could not be displayed.

Hi Ben, Same issue here. Any luck.

This widget could not be displayed.

Hi ,

Did you tried , the integrety checker?

https://confluence.atlassian.com/display/JIRA/Using+the+Database+Integrity+Checker

Regards,

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Tuesday in Jira

What modern development practices are at the heart of how your team delivers software?

Hey Community mates! Claire here from the Software Product Marketing team. We all know software development changes rapidly, and it's often tough to keep up. But from our research, we've found the h...

137 views 1 3
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you