Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Issue with the date fields

Hi Team,

Project team is facing an issue with the field called : Date R&D Delivery" and "Date into working" which are getting auto populated with the system date, see screenshot below.

There are 2 scenarios:

1. Issue Type: Customer Claim ,  Product Division: Nottigham

Dates are getting auto populated with the system date, see 1st screenshot-CPMCU-4052

Nottingham-CPMCU-4052.png

 

 

2. Issue Type: Customer claim,  Product Division: Valence

Dates are not getting populated with the system date, see below screenshot:

Valence-CPMCU-4058.png

We are facing this issue from long time, for the same issue type, but different product division value, date fields are not working as expected.

Please need your help in it.

 

Regards,

Neeta Jain

 

 

3 answers

1 vote
Liam Green Community Leader Dec 08, 2020

Hi Neeta

If you go to the following address, you can log the issue:

https://support.atlassian.com/contact/#/

Thanks, Liam

0 votes
Liam Green Community Leader Dec 01, 2020

Hi @njain2_markem-imaje_com 

Do you have automation set up to pre-populate the fields?

Hi Liam,

 

How do I check that automation is set or not?

 

Regards,

Neeta Jain

Hi @njain2_markem-imaje_com ,

You can check the issue history tab to see whether there is an Automation rule working in the back. If it does, you'll see issue changes made by the Automation by Jira.

Cheers,

Gökçe

How to check automation rule?

You can go to Project Settings>Automation to see your automation rules.

Also, You can click on the History tab right above the Comment section of the issue view to check whether the Automation app does changes to your issue. 

Hi,

Under project settings I don't find any option for Automation.

And I have checked in the history as well, no such automation.

But one thing, its working fine for product division: Valence, but taking system date for the product division: Nottingham.

 

Even though same issue type is created for both the product division and same workflow shared for both.

 

Regards,

Neeta Jain

Hi Neeta,

It looks like this for Software projects:

Screen Shot 2020-12-02 at 12.45.29.pngIn Service Management projects, it's near SLAs section.

Screen Shot 2020-12-02 at 12.56.49.pngSince you have mentioned that the WF is the same, I can't suggest checking the post functions.

One other possibility is another app setting those fields. Could you check which apps are installed in your instance?

Hi,

I have find the Project Automation option, and under that I can see:

Automation.PNG

When you click on 'All Rules', there are no rules listed right? If this is the case then, I believe there are no Automations affecting those fields. 

How about other apps installed in your instance? Also, is it possible for you to share a screenshot of the affected issue?

Yes, there are no rules listed.

Apps like scriptrunner, easyBI are installed on the system.

I have already shared the issues screenshots, please check or else I will share it again.

The history tab is not present in the screenshots but no worries. 

Can you check the Script Runner app then? Maybe there is a script listener or scheduled job configured?

Hi,

I have checked the script runner as well, there is no script listener or scheduled job configured.

 

Regards,

Neeta Jain

Well, I'm out of ideas. @Liam Green  you have any other ideas?

Liam Green Community Leader Dec 03, 2020

@Gokce Gursel _Snapbytes_ - I'm out of ideas too!

@njain2_markem-imaje_com - I think your best option here is to log the issue with Atlassian to see what they can do.

Hi Liam,

 

Can you please mention the steps to log the issue with atlassian?

 

Regards,

Neeta Jain

Hi All,

I have disabled automated addon on TEST instance and tried with the new issue creation, now date fields are not getting auto populating.

 

But on PROD instance of JIRA I can not disable the addon like script runner, JMWE, JSU etc. then how can I resolve this issue.

Kindly help.

 

Regards,

Neeta Jain

Liam Green Community Leader Dec 10, 2020

Hi Neeta

If you contact Atlassian using the below link they should be able to help:

https://support.atlassian.com/contact/#/

Thanks, Liam

You need to try disabling automation add-ons one by one, until the fields stop being populated. That will allow you to identify which add-on is auto-populating the fields.

Then, depending on the add-on, you'll need to check its configuration.

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PRODUCT PLAN
STANDARD
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you