Issue with jira.user('myuser',expand="groups").groups


I suspect an issue with jira-python. Here is the issue : when I try to get groups a user is a member of,I can't get them using groups property as follow :


AttributeError: 'Resource' object has no attribute 'name'

If I check the raw data for the user I see the groups :


{u'active': True,


u'expand': u'groups',

u'groups': {u'items': [{u'name': u'Internal',

u'self': u'https://xxxxx/rest/api/2/group?groupname=Internal'},

{u'name': u'Tech Team',

u'self': u'https://xxxxx/rest/api/2/group?groupname=Tech+Team'},

u'size': 2},

u'key': u'myuser',

u'name': u'myuser',



The only way I found to get the information is :


any idea how to get it without using raw ?

1 answer

I tried this with Python 2.7.3 and jira-python 0.25, and it worked for me. I don’t know why you got an AttributeError.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Jan 08, 2019 in Jira

How to Jira for designers

I’m a designer on the Jira team. For a long time, I’ve fielded questions from other designers about how they should be using Jira Software with their design team. I’ve also heard feedback from other ...

1,086 views 4 9
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you