Issue with HTML tag using documentation theme and user macro

Hello all -

I'm attempting to customize my header using the Documentation theme, and I'm having a problem with wiki markup that uses HTML/javascript.

For demo purposes, here is my User Macro (let's call it {foo})

<script>
function test(name){
    alert('hello ' + name);
}
</script>

<span style="background: green; color: white; padding: 4px 12px; \-moz-border-radius:4px; \-webkit-border-radius: 4px;">GREEN

<select>
  <option>Milk</option>
  <option>Coffee</option>
  <option>Tea</option>
</select>

<input value="ButtonName" type="button" onclick="test('hooray')" >

</span>

The issue is, that when customizing the Documentation theme by simply calling {foo} in the header, the contents of the <script> entity are spammed to my Confluence page!

The javascript works, but unfortunately my page header now has the function definition echo'd as text... not exactly what I'm going for :P

Any help is appreciated.... and thank you!

- js

1 answer

This widget could not be displayed.

*bump* ....

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Tuesday in Jira

What modern development practices are at the heart of how your team delivers software?

Hey Community mates! Claire here from the Software Product Marketing team. We all know software development changes rapidly, and it's often tough to keep up. But from our research, we've found the h...

113 views 1 2
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you