Is there a way to get "Create Issue" event to fire a webhook when a JQL query is provided?

I have a webhook set up which works as intended when no JQL is provided, however when a jql is added, the "Create issue" event doesn't fire a message. The JQL is correct because the webhook would fire when there is a different kind of event like update issue. The JQL is just a simple: project = projectxyz

I've seen some people mention this before, but haven't seen an actual solution so I was wondering if there was a way to make this work

2 answers

0 vote

I guess the issue is indexed only after the creation. Try putting the post function at the very end and see if it helps!

A solution that I found was that I just added a function in the create workflow to re-index the issue before an event is fired for the listeners

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Posted 7 hours ago in Jira

We want to know what Jira Service Desk apps you're using!

Hi Community! My name is Amir and I’m on the Jira Service Desk product marketing team at Atlassian. Our team would love to understand how you’re leveraging our ecosystem for Jira Service Desk. Wha...

26 views 0 5
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you