Internet Explorer 8 and the Issue Collector

I just cannot get the issue collector to work in IE8. It works in firefox and chrome, but just doesn't render properly and is mostly unusable in IE 8 for me.

On some pages i get a messed up dialog (it's too wide for the page, and sometimes the cancel\close button doesn't work) and then when i try to embed it on some other pages i get out of memory errors when i click on the feedback button.

The question below was self answered, but i didn't get any insight into what the solution was such that i could give it a go for myself. The symptoms looked the same though...

https://answers.atlassian.com/questions/96002/ie8-won-t-render-all-fields-in-custom-issue-collector-what-s-wrong

4 answers

1 accepted

3 votes
Accepted answer

I researched a lot for this and finally found the answer

Unzip the issue collector code.

Modify \templates\collector\custom.vm and add meta tag to support compatibity mode as shown below.

Zip the jar again and update the issue collector resolved the issue for me

<head>
<meta http-equiv="x-ua-compatible" content="IE=EmulateIE8"/>
<script type="text/javascript">
var contextPath = "$baseurl";
</script>
$webResourcesHtml
</head>

Prajwal T. Thank you very very much for this solution! - We ran across this formatting problem while trying to implement the issue collector in the .net web browser control (which relies on the IE rendering engine)... After trying many different things with no success we had all but given up hope on allowing the user to provide feedback directly to Jira from within our software. This solution has fixed the formatting problems and put the option back on the table for us!

To those who are relatively new to Jira like myself the following might help:

1/ You must download the plugin from the atlassian website

2/ Edit the code on your computer as per P.T.'s post (using a html editor such as CoffeeCup)

3/ Upload and install the new and edited plugin using the 'Upload Plugin' option in Jira's 'Install Plugins' tab (which I wasn't aware you could do...)

Again, thanks for the solution,
Regards,

Michael

I found that you have to follow the guide at the JIRA Administration Guide>>Advanced Use of the JIRA Issue Collector if you are doing anything with a Custom Collector. It really helped us get this straighten out with IE.

https://confluence.atlassian.com/display/JIRA/Advanced+Use+of+the+JIRA+Issue+Collector

Thanks,

John V.

Do you have any other plugins installed?

I had a simular issue with Jira Suite Utilities installed but the incorrect version for the release of Jira I had installed.

If you go into the plugins and disable any other plugins and then see if the issue is no longer there then turn them on one by one testing after re-enabling to find the plugin causing the issue.

Hope this helps :)

0 votes
Joe Wai Tye Atlassian Team Oct 18, 2012

Just to check, but do you have 'Compatibility Mode' on for your IE8? It's known to cause some problems.

Try disabling it (if it is enabled) and see if the problem persists

Thanks for all the info, everyone. Joe it was as simple as the compatability view, thanks. As soon as i turned it off, all worked perfectly.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Nov 27, 2018 in Portfolio for Jira

Introducing a new planning experience in Portfolio for Jira (Server/DC)

In the past, Portfolio for Jira required a high degree of detail–foresight that was unrealistic for many businesses to   have–in   order to produce a reliable long-term roadmap. We're tur...

2,409 views 15 19
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you