Integrating Jira into Confluence: Application Links works fine, however...

We have our test environment setup as follows:

JIRA and Confluence are setup on the same server box. Thus both apps will share their machine's ip (except for the port numbers are).

I've configured on application links on both apps, setting up trusted applications, and they're configured properly - no issues.

However when trying to test this, I logged onto Confluence, created a page, go to Insert -> Jira Issue, I could not find any JIRA issues in the dropdown list.

I looked up the atlassian-confluence.log file, and I found this line.

WARN anonymous 871x6512x1- xxxxxxx /sr/jira.issueviews:searchrequest-xml/temp/SearchRequest.xml [auth.trustedapps.filter.TrustedApplicationFilterAuthenticator] Failed to login trusted application: confluence 9123435 due to: com.atlassian.security.auth.trustedapps.InvalidCertificateException: Request not allowed to access URL: /sr/jira.issueviews:searchrequest-xml/temp/SearchRequest.xml

I set the URL Pattern configuration settings for JIRA as folllows:

/plugins/servlet/streams, /sr/jira.issueviews:searchrequest, /secure/RunPortlet, /rest, /rpc/soap,

I still could not understand why it doesn't work despite the above setup. And I can confirm that our JIRA's database is prepoulated with lots of JIRA issues so the database could not be empty.

So what's wrong with our trusted authentication setup? Any ideas??

5 answers

1 accepted

Hi all,

I found the fix to this issue.

Apparently, there's a separate installation guide for integrating JIRA and Confluence seamlessly.

https://confluence.atlassian.com/display/ATLAS/Here+Be+Dragons

So I had to uninstall and reinstall both our JIRA and Confluence, reinstalled the CORRECT versions as per the above link. (formerly, JIRA 5.1.1 and Confluence 4.2.11) and now it works again.

It's also works with our JIRA's production data copy on our JIRA Eval database too - so it's all looking good now!

Thanks for the help

Are you both logged into JIRA and Confluence when you're trying to insert the issue?

Yes. I logged on as my own account, for both JIRA and Confluence. ie I have two accounts named "andy" setup in JIRA and Confluence respectively.

Do you have XML-RPC enabled on both Confluence & JIRA?

I checked. JIRA's xml rpc is enabled. Confluence wasnt'.

I enabled xml rpc on Confluence, logged out and log back in. Still the same issue.

The error logs comes up the same error message..

Also. Do I need to restart the JIRA and Confluence services after enabling xml rpc?

Well, it says "com.atlassian.security.auth.trustedapps.InvalidCertificateException" - is a server on HTTPS but invalid?

I've done the same on mine and it works fine.

I personally have not changed anything in the "URL Pattern configuration settings for JIRA"

M.

invalid HTTPS? I didn't realise HTTPS protocol is part of the JIRA/Confluence setup. I couldn't find it anywhere in the documentation?

https://confluence.atlassian.com/display/JIRA/Configuring+Trusted+Applications+Authentication+for+an+Application+Link

Where in JIRA can I find the HTTPS configuration settings?

I didn't mean that JIRA internally uses https - I meant: did you host JIRA on https?

No I didn't. And our JIRA is hosted internally - meaning it's for private access, not public access.

We didn't configure JIRA to use HTTPS for internal use either.

We're using an evaluation licence for Confluence, whilst our JIRA server installation is a copy of our production JIRA server. We're currently in the process of evaluating the latest JIRA software version before making decision to buy it.

We have similar setup like yours and we use Crowd to get users from Active Directory. I use internal Crowd users and groups to help manage non-AD users, like dedicated accounts for application links. My experience with setting up application links(Without using Crowd):

  • I have dedicated application link accounts on both Confluence and JIRA, 1 account each.
    • Eg: applink with the same password on both instances so I dont get confused.
  • In JIRA, applink is in jira-users and jira-administrators group.
    • This would take care of the global permissions for me for the applink account.
  • In Confluence, applink is in confluence-users and confluence-administrators group.
    • This would also take care of the global permissions for me in Confluence.
  • Then the application links created from either machine will use this applink account.

Hope this helps.

Thanks KY Lee. I found the fix to my own issue below. :)

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Julia Dillon
Posted Apr 17, 2018 in Jira

Tell us how your team runs on Jira!

Hey Atlassian Community! Today we are launching a bunch of customer stories about the amazing work teams, like Dropbox and Twilio, are doing with Jira. You can check out the stories here. The thi...

771 views 2 19
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you