Integrating JIRA with IIS and ARR

I have been trying to Integrate JIRA with IIS using the Application Request Routing extension and have successfully managed to get it setup but there are still some elements that are not rewriting properly and therefore cause a 404 error. I am not sure exactly what I am missing. I am using IIS8 and used the documentation listed at http://www.iis.net/learn/extensions/url-rewrite-module/reverse-proxy-with-url-rewrite-v2-and-application-request-routing to help me. We are using http://server/jira as the ProxyName. When I use Chrome to Inspect my Dashboard page I see the following:

GET http://server/s/en_AUbykrj8-418945332/844/6/1.0/_/images/icons/add_20.png 404 (Not Found) batch.js:5

GET http://server/s/en_AUbykrj8-418945332/844/6/1.0/_/images/icons/edit_20.png 404 (Not Found) batch.js:5

GET http://server/s/en_AUbykrj8-418945332/844/6/1.0/_/images/icons/tools_20.png 404 (Not Found) batch.js:5

GET http://server/s/en_AUbykrj8-418945332/844/6/3.2.0-m2-1/_/download/resources/com.atlassian.gadgets.dashboard%3Adashboard/css/images/menu_indicator_for_light_backgrounds.gif 404 (Not Found) batch.js:5

GET http://server/s/en_AUbykrj8-418945332/844/6/5.1.6/_/download/resources/com.atlassian.streams:streamsWebResources/images/gadget-loading.gif 404 (Not Found) com.atlassian.auiplugin:jquery-lib.js:4

GET http://server/s/en_AUbykrj8-418945332/844/6/5.1.6/_/download/resources/com.atlassian.streams:streamsWebResources/images/throbber.gif 404 (Not Found) com.atlassian.auiplugin:jquery-lib.js:4

GET http://server/s/en_AUbykrj8-418945332/844/6/5.1.6/_/download/resources/com.atlassian.streams:streamsWebResources/images/feed-icon.png 404 (Not Found) com.atlassian.auiplugin:jquery-lib.js:4

GET http://server/s/en_AUbykrj8-418945332/844/6/5.1.6/_/download/resources/com.atlassian.streams:streamsWebResources/images/full-view-icon.png 404 (Not Found) com.atlassian.auiplugin:jquery-lib.js:4

GET http://server/s/en_AUbykrj8-418945332/844/6/5.1.6/_/download/resources/com.atlassian.streams:streamsWebResources/images/list-view-icon.png 404 (Not Found) com.atlassian.auiplugin:jquery-lib.js:4

GET http://server/s/en_AUbykrj8-418945332/844/6/5.1.6/_/download/resources/com.atlassian.streams:streamsWebResources/images/filter-view-icon.png 404 (Not Found) com.atlassian.auiplugin:jquery-lib.js:4

GET http://server/s/en_AUbykrj8-418945332/844/6/5.1.6/_/download/resources/com.atlassian.streams:streamsWebResources/images/arrow-right.png 404 (Not Found) com.atlassian.auiplugin:jquery-lib.js:2

GET http://server/s/en_AUbykrj8-418945332/844/6/5.1.6/_/download/resources/com.atlassian.streams:streamsWebResources/images/bullet.png 404 (Not Found) com.atlassian.auiplugin:jquery-lib.js:2

GET http://server/s/en_AUbykrj8-418945332/844/6/3.2.0-m2-1/_/download/resources/com.atlassian.gadgets.dashboard%3Adashboard/images/icons/gadget-tools.gif 404 (Not Found) batch.js:4

GET http://server/s/en_AUbykrj8-418945332/844/6/5.0-m10/_/download/resources/com.atlassian.auiplugin:ajs-gadgets-base/aui-icon-tools.gif 404 (Not Found) batch.js:4

I have included application/javascript in my outbound rewrite rule and application/x-javascript but this is still generating the errors... is someone able to help?

2 answers

1 accepted

With the help of Atlassian Support we have managed to get to the bottom of the issue. While I still can't get ARR to work with the http://server/jira URL I have finally got ARR working with http://jira.domain.local.

The problem was with the Context Path. I had the path="/" when it needs to be path="". Once we made that change everything started working again.

Hi Phillip,

I'm not sure what's wrong with your configuration, but it seems to me quite different than what we have here and I know that works very well.

Cheers

Hi Tiago,

I have seen this page and followed the instructions there but it still does not work for us. Because we are using http://server/jira as the path, instead of creating a new site, I create a Virtual Directory. I then create the URL Rewrite rule and I get the home page but it looks like this...

When I mouse over any of the links they are http://server/{link} and not http://server/jira/{link}

This suggests that an outbound rule is required to rewrite the links, but my outbound rule creates the issue previously described.

If you have any other suggestions, please let me know!

Hi Phillip,

I'll have to test a little further with a Virtual Directory, but just checking two basic settings to make sure they are correct:

  • Do you have a context path configured into the server.xml:
    <Context path="/jira" docBase="${catalina.home}/atlassian-jira" reloadable="false" useHttpOnly="true">
  • Is your base URL set to http://server/jira

Cheers

Hi Tiago,

I did try that but do not exactly remember the results. I am certain when I added "/jira" to the context path, I ended up with a URL that was http://server/jira/jira instead of just http://server/jira. When this happened, somethings worked and somethings didn't.

And yes the base URL is set to http://server/jira.

To be honest I am also testing the http://jira.domain.local option and have found that it works fine, except for one thing. When I log in, I get the yellow warning bar at the top of the page saying that:

"JIRA's base URL is set to http://jira.domain.local but you are accessing JIRA from http://jira.domain.local. Click here to update your settings. Alternatively, hide this message"

When I click here to update the settings, I am prompted to enter my password again and then when I click Confirm, I get nothing. The page does not load, and the URL changes to http://secure/admin/WebSudoAuthenticate.jspa. It totally does not use the Base URL. Is there somewhere else I am missing in updating the configuration?

I should also mention that I have changed the Proxy Name to be "jira.domain.local" and changed the Context Path back to be just "/"

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published Sunday in Agility

You asked for it, so we delivered: images on issues have arrived

A picture tells a thousand words. And agility boards have just released their latest feature: cover images on issues – so now your board can tell a story at first glance. Upload attachmen...

289 views 3 11
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you