Installing Jira (download) - Running Jira with dedicated user account Runas error?

Hey guys,

I'm trying to install Jira on my server and I'm following the instructions.

I believe I'm almost done and when I try to run Jira with a dedicated user account which I was successful to create (user jira) I get an error.

This is what I'm doing on CMD:

runas /env /user:<DOMAIN>\jira start-jira.bat

After that it asks me for the password and when I type it in I get the following error:

RUNAS ERROR: Unable to run - start-jira.bat

2: The system cannot find the file specified

Anyone knows what seems to be the problem?

Thank you :)

3 answers

This widget could not be displayed.

Try to use the full path for start-jira.bat. If I remember well, on windows there are several switches which affects the current path of the runas command.

I tried doing the following as well:

runas /env /user:<DOMAIN>\jira C:\Program Files\Atlassian\JIRA\bin\start-jira.bat

but I received a list of instructions on how to use "Runas" properly instead of getting a sresult, perhaps I'm not using it right when it comes to typing in a dir, can't really understand the instructions.

Also tried runas /env /user:<DOMAIN>\jira "C:\Program Files\Atlassian\JIRA\bin\start-jira.bat" and it does ask me for a password though afterwards I get:

Attempting to start C:\Program Files\Atlassian\JIRA\bin\start-jira.bat as user "<DOMAIN>\jira" ...

And nothing happens

Since you have spaces in path, the second one should work, not the first one.

You will have to make sure that the profile is correctly set (check if JAVA_HOME is set for that user, etc)

runas /env /user:<DOMAIN>\jira "C:/Program Files/Atlassian/JIRA/bin/start-jira.bat"

should do it. However, if you do not provide an error or something, there's little I can do, too many things may go wrong.

Not sure how to check if the profile is correctly set for the user..

Under system Variables I have JIRA_HOME set to value of C:\Program Files\Atlassian\Application Data\JIRA and JAVA_HOME set to value of C:\Program Files\Java\jdk1.7.0_04

Thanks a lot for your feedback ! :)

Jira works with JDK 1.6, not with 1.7

Downloaded 1.6 and redirected JAVA_HOME to it though nothing seems to change (also, the Jira instructions page doesn't state that only JDK 1.6 should be downloaded)

Thanks !

This widget could not be displayed.

i have the same issue guys... any solution yet? Thanks!!

This widget could not be displayed.

Jira install scirpt didn't create a dedicated user account

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted 14 hours ago in New to Jira

Are you planning to trial, or are currently trialling Jira Software? - We want to talk to you!

Hello! I'm Rayen, a product manager at Atlassian. My team and I are working hard to improve the trial experience for Jira Software Cloud. We are interested in   talking to 20 people planning t...

41 views 1 0
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you