Installation works, but cannot configure/start/use gantt chart plug

Nicht gefunden (404)

Error creating bean with name 'de.polscheit.jira.plugins.config.Admin': Unsatisfied dependency expressed through constructor argument with index 0 of type [com.atlassian.jira.license.JiraLicenseManager]: : No unique bean of type [com.atlassian.jira.license.JiraLicenseManager] is defined: Unsatisfied dependency of type [interface com.atlassian.jira.license.JiraLicenseManager]: expected at least 1 matching bean; nested exception is org.springframework.beans.factory.NoSuchBeanDefinitionException: No unique bean of type [com.atlassian.jira.license.JiraLicenseManager] is defined: Unsatisfied dependency of type [interface com.atlassian.jira.license.JiraLicenseManager]: expected at least 1 matching bean

Das Gesuchte konnte nicht gefunden werden. Vielleicht sollten Sie einen Vorgang erstellen.

7 answers

1 accepted

This widget could not be displayed.

This is a problem of JIRA's plugin sandboxing: if two or more plugins have specified an admin-action with the same key but different plugin scopes, JIRA does not handle this correctly. The workaround is to rename this admin-action to become unique.

Please download pre-v2.2 from my server, depending on your current JIRA version:

I hope, this helps in your case, too!

Regards,
Frank

This widget could not be displayed.

It looks like, you have a component version conflict: please ensure, that the Atlassian Universal Plugin Manager (UPM) is the same version as mentioned within my Gantt-Chart version name (for the current latest, it should be version UPM 2.8.x).

What's your UPM version (see: system plugins)?

Regards,
Frank

UPM 2.7.8, but deactivated!

Cannot activate. Getting error: Dieses Plugin konnte nicht aktiviert werden. Ihre Lizenz ist möglicherweise ungültig. Weitere Informationen entnehmen Sie bitte den Protokollen.

Plugin-Überwachungsprotokoll


Fehler beim Aktivieren des Plugins Atlassian Universal Plugin Manager Self-Update Plugin (com.atlassian.upm.atlassian-universal-plugin-manager-selfupdate-plugin)

Despite the UPM 2.8.1 update failing. If Gantt-Chart-Plugin only requires UPM 2.8, we might be assuming a depenency that does not exist and the two issues are unrelated, i.e. we should continue troubleshooting the Gantt-Chart-Plugin issues independent of the UPM 2.8.1 issue?

This widget could not be displayed.

That's not a topic of my Gantt-Chart addon, but a general problem with your JIRA instance. Please contact your Atlassian support: without activated UPM, the license management cannot work!

Regards,
Frank

UPM is activated. Jira is licensed.

Universal Plugin Manager wurde erfolgreich gestartet

Gantt Chart Plugin is the only plugin of almost 10 that does not work.

The only Jira issue seems to be the failing update of the Universal Plugin Manager Self-Update Plugin.

Any ideas?

This widget could not be displayed.

I suggest to download the UPM v2.8 from the Atlassian Marketplace and install it via the "upload" button on "manage plugins" in order to work around that problem with the self-update.

Does this work for you?

UPM is 2.1.8.2-JIRA5.2-UPM2.8

Update to 2.8.1 fails through automativ update and manual upload.

How do I get in touch with Atlassian. Is there any support email or button or URL to submit issues?

This widget could not be displayed.

Try https://support.atlassian.com/secure/Dashboard.jspa and register for getting an account, if you do not already have one. Alternatively, you can contact sales@atlassian.com in order to get a support contact.

This widget could not be displayed.

Despite the UPM 2.8.1 update failing. If Gantt-Chart-Plugin only requires UPM 2.8, we might be assuming a depenency that does not exist and the two issues are unrelated, i.e. we should continue troubleshooting the Gantt-Chart-Plugin issues independent of the UPM 2.8.1 issue?

This widget could not be displayed.

Hello Frank, Atalassian pointed me to a plug-in conflict and I can confirm deactivating Xporter Plugin for Jira does solve the issue and Gantt Chart Plugin does work now.

You might want to get in touch with the developer Xpand IT to sort out the issue.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Tuesday in Jira

What modern development practices are at the heart of how your team delivers software?

Hey Community mates! Claire here from the Software Product Marketing team. We all know software development changes rapidly, and it's often tough to keep up. But from our research, we've found the h...

247 views 1 3
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you