Importing Excel File;Can't Proceed Past Map Fields Page

Hello,

I'm currently exporting an Excel .xls file (1 MB) to no success. I was able to upload the file successfully and assigned it to a specific project as intended. When I get to the "Map Fields" page I'm being notified that " A JIRA Summary field mapping is required to enable import". The only CVS Field is see is "<html xmlns:o=urn:schemas-microsoft-com:office:office" but I'm unable to select it. I get the option to select a "JIRA Field" and "Map Field Value" but any JIRA Field I select does not allow me to proceed beyond the MAP Field page. The NEXT button is grayed out.

Any help is greatly appreciated on helping resolving this issue.

Thank You

JIRA Version 6.2-OD-03 OnDemand

2 answers

1 accepted

0 votes

When you export to Excel from Jira, what it actually creates is an XML file that says "I'm a spreadsheet" to anything that opens it. This is not a csv file, it's xml.

When you save a new Excel spreadsheet, it defaults to Excel format. This also is not a csv file, it's an Excel file.

Neither of these file types can be imported, as the csv importer expects csv. You need to convert your data to csv, which is actually a doodle - open the file in your spreadsheet and then use either "save as" or "export to csv" and save the result. Then upload that into the csv importer instead.

Hi Nic,

Unfortunately, I'm still encountering the same issue even after converting the file to CVS. :/

Hi Nic,

Thank you much for replying to my question, unfortunately, I'm still encountering the issue. I opened up the .xsl file and saved it as a CVS file. I uploaded the file successfully and assigned it to a specific project. When I get to the MAP Fields page, I chose any JIRA Field option and the NEXT button still appears grayed out. I upload the file.

My steps:

Upload CVS file.

I keep the default UTF-8 file encoding.

Assign to a specific project.

Stuck on Map Fields page.

I have attached a screenshot of my issue.

Thanks! :)

The following text appears on the Map Field page:

Working with multiples

For issues with multiple attachments, versions, components or comments use multiple columns in your CSV file. Use either: Different column names like Attachment 1, Attachment 2 then map each column to a corresponding JIRA field, or use the same column name (they will be mapped to the selected field).

Custom fields

Existing custom fields must be global to all projects.

Sub-tasks

To import issues as sub-tasks define the column mapping for: Issue Id, Parent Id and Issue Type

Empty headers

CSV file has at least one empty header, corresponding column will not be imported.

Ok, could you take the csv file and open it in a simple text editor (vi, nano, notepad - not wordpad or anything more clever). No need to change anything, we just want to check the format.

Tell us what the first three lines say (feel free to obscure any data you don't want to share - we're interested in format, not data)

Here's are the first lines that appear after opening the csv file with Notepad

KFF Task Tracker,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,
Displaying 243 issues at 19/Nov/13 5:29 PM.,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,,
Project,Key,Summary,Issue Type,Status,Priority,Resolution,Assignee,Reporter,Created,Last Viewed,Updated,Resolved,Affects Version/s,Fix Version/s,Component/s,Due Date,Watchers,Images,Original Estimate,Remaining Estimate,Time Spent,Work Ratio,Sub-Tasks,Linked Issues,Description,Progress,? Progress,? Time Spent,? Remaining Estimate,? Original Estimate,Labels,Story Points,Flagged,Testing Status,Epic Link,Rank,Sprint,Platform,MANTIS_ID,Epic/Theme,Raised During,Test Sessions,[CHART] Date of First Response,Milestone

Ahh, ok, yes, we're getting there. The problem now is that the sheet you've saved has header and footer information. The importer requires a single line of header (Project, Key, Summary, etc) and then one row of data per issue to import.

The safest thing to do is go back to the spreadsheet, and remove the lines at the top that have header stuff in them. Have a look for the footer as well, you'll want to strip that off the bottom. Save the trimmed file as a CSV again and try to import that.

The issue appeared to be that my sheet had header and footer information. Once I deleted those fields from the sheet I was able to proceed as normal.

Thank you so much Nic!

:)

I am having the same issue.  I do not have a header or footer.  The fields show up on the Map Fields page from the CSV.  But the "next" button is never enabled even after mapping.

@Scott Peiffer I also facing same issue, did you got any solution yet !! #PleaseUpdate.

This is rather an old question to be commenting on, and I missed the first comment last month.

In later versions, the next button will be greyed out until you have a valid mapping - make sure there's a summary mapped to a column that has content on every line.  If you've got a project column, check the mappings in there, same for issue type, etc.

@Scott Peiffer laugh I tried with one by one combination, and add Mapping for Summary field worked to enable next button. Try your own once.

Suggest an answer

Log in or Join to answer
Community showcase
Sarah Schuster
Posted Jan 29, 2018 in Jira

What are common themes you've seen across successful & failed Jira Software implementations?

Hey everyone! My name is Sarah Schuster, and I'm a Customer Success Manager in Atlassian specializing in Jira Software Cloud. Over the next few weeks I will be posting discussion topics (8 total) to ...

2,943 views 12 18
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot