IMAP Mail Server setup fails

I am trying to configure an IMAP-Account in order to create/comment issues in JIRA via email.

After following the documentation, it is still not working. Following is my setup:

Name: Exchange 2013
Description: xyz
Protocol: IMAP
Host name:10.50.1.10
IMAP Port: 143
Timeout: 10000
Username: xyz
Password: xyz
"Test connection" returns the following error:

Unfortunately no connection was possible. Review the errors below and rectify:

  • ProtocolException: No login methods supported!



1 answer

1 accepted

0 vote

That usually means that your mail server requires a certain type of login, which is not what you have configured.  Or that it simply is not set up for IMAP at all.  You'll need to talk to the server admins.  Exchange 2013 sadly ships with IMAP disabled in favour of the inferior MAPI protocol, so it could be that.

The only way I got Incoming Mail to work is if I set the authentication in Exchange for IMAP to Basic Authentication (Plain Text). Is there any way to get it to work using Secure TLS authentication

Ah, sorry, I really should have remembered that as well, as I never recommend using an unencrypted connection - should always be StartTLS or IMAPS. Problem with StartTLS is that Java doesn't do it unless you explicitly kick it into working. To do that, add -Dmail.imap.starttls.enable=true to the startup parameters in setenv.sh

I was able to add this parameter by following this link https://confluence.atlassian.com/display/JIRAKB/%27javax.mail.MessagingException+No+login+methods+supported%27+Due+to+IMAP+over+SSL Now I'm getting error "SunCertPathBuilderException: unable to find valid certification path to requested target". I tried to follow the instructions of the link "Connecting to SSL services" in the document referenced above by using the JIRA SSL Atlassian plugin referenced on that page but I'm getting error "class javax.net.ssl.SSLException during connection to..." Jira is installed locally on a windows server 2012

So the -D parameter works and enables StartTLS, but now your certificates are not installed correctly. You'll need to import the right certificates into the java keystore, and ensure the process running Jira has the correct permissions to read/write it...

After importing SSL certificates for the wembail server using the JIRA SSL Atlassian plugin and restating Jira the connection was successful.

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published Jun 14, 2018 in Jira Service Desk

How the Telegram Integration for Jira helps Sergey's team take their support efficiency to the bank

...+ reading Fantasy). The same is true for him at the bank he works for: Efficiency is key when time literally equals money. Read on to learn how Sergey makes most of the time he has by...

552 views 3 5
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you