IIS Integration with Stash - Application Link to JIRA fails

I recently installed Stash and set up a reverse proxy several ways. In the end I used https://confluence.atlassian.com/display/JIRA/Integrating+JIRA+with+IIS as reference and applied it to the Stash installation. Using this method, there were no problems at all. However when go to link my installation of JIRA (on a remote machine) and Stash, nothing happens when I enter in my system administrator's credentials on the second step in the wizard. I checked the Chrome Dev Tools Console and I am presented with:

POST https://domain.com/stash/rest/applinks/1.0/applicationlinkForm/details 400 (Bad Request) batch.js:4

send batch.js:4

f.extend.ajax batch.js:4

AJS.$.extend.jsonRequest batch.js:16

AJS.$.extend.post batch.js:25

AJS.$.extend.SPI.AJS.$.extend.verifyTwoWayLinkDetails batch.js:57

AppLinks.Wizard.checkReciprocalLinkForm batch.js:643

L.onnext batch.js:1130

(anonymous function) batch.js:507

A._onclick batch.js:206

f.event.dispatch batch.js:3

h.handle.i batch.js:3

Uncaught SyntaxError: Unexpected token B batch.js:2

e.extend.parseJSON batch.js:2

(anonymous function) batch.js:163

n batch.js:2

o.fireWith batch.js:2

w batch.js:4

d batch.js:4

Is this a bug in the system, or something that I can fix within the configuration settings?

2 answers

1 accepted

This widget could not be displayed.

It looks like this was not a Stash issue at all. The server that houses JIRA was not configured correctly so it was unable to reach the Stash server.

This widget could not be displayed.

Hi Greg.

I believe the JIRA documentation doesn't mention the proxyPort parameter:

...
scheme=
"http"
proxyName="mycompany.com"
proxyPort="80" />
Could you please add it to your I server.xml, restart the application and then try again?
Now if you are using HTTPS you will need to add the secure parameter:
secure="true"
scheme="https"
proxyName="mycompany.com"
proxyPort="443" />
Please let me know how it goes.
Cheers,
Douglas Fabretti
Atlassian Support

I was using AJP instead of HTTP. However, it was not a problem within the application. It was an issue with the server. Thanks for the help.

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted Wednesday in New to Jira

Are you planning to trial, or are currently trialling Jira Software? - We want to talk to you!

Hello! I'm Rayen, a product manager at Atlassian. My team and I are working hard to improve the trial experience for Jira Software Cloud. We are interested in   talking to 20 people planning t...

292 views 5 0
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you