I tried to import my test cases using Zephyr Test case importer but it display 401 error for some reason

Hi Team,

Below are the follow steps which I followed to connect to the server.

Step 1: Entered the URL

Step 2: Keyed in my Username and Password which is related to my company URL from step1

Step 3: Copied the Access key and Secret key to the clipboard from JIRA

Step 4: Grabbed the Access key and Secret key from the clipboard

Step 5: Pasted those in Zephyr Test case Importer tool 

Step 6: Clicked on "Connect"

 

Then I see an Error fetching the project window with unexpected response code 401 error.

Can guys please resolve the issue or let me know if I em missing anything in the flow.

 

 

Cheers,

Raj

5 answers

This widget could not be displayed.

Hello, everybody.

I'm facing exactly the same problem. I perform identical steps as Raj and I get the same error screen. The records from logs suggest that I'm using incorrect credentials, but I don't think it's the case. I've just logged into JIRA usig the same login and password (and I tried it on two different users).Still the same. I also regenerated API keys as you suggested in response to Raj's problem. Could you please verify if we're doing thigs right.

LOG ENTRY:

2015-06-25 21:25:39,139 WARN [AWT-EventQueue-0] ConfiguredHttpClient.handleResponse(1097) | Authentication error: Unable to respond to any of these challenges: {oauth=WWW-Authenticate: OAuth realm="https%3A%2F%2Fit-project.atlassian.net"}

 

Thanks in advance,

Sebastian

This widget could not be displayed.

 

25-06-2015 4-12-15 p.m..png

 

Screenshot for the Above issue

This widget could not be displayed.

Hello Saigiriraj,

 

Could you please double check the username and password of JIRA. Also please try to regenerate API keys and then use the same in importer. Please access through the below link for the knowledge based documentation to import tests in Zephyr for JIRA cloud.

https://support.getzephyr.com/hc/en-us/articles/204550179-How-do-I-import-test-cases-into-Zephyr-for-JIRA-Cloud-

Please raise a support ticket with us by access through the below link,if the issue persists.

https://support.getzephyr.com/hc/en-us

 

Regards,

Zephyr Support. 

 

This widget could not be displayed.

Hello,

I'm seeing the same issues that were reported above where i receive the following error message when I try to connect to the importer: "Unexpected response code: 401"

I have confirmed that I am entering in the correct username/password and have regenerated the API keys, but I still receive the same error. Has there been any resolution to the problems that everyone has been facing?

Thanks,

Alex

This widget could not be displayed.

for your user name, use the User Name that is in your JIRA account and not your email address.  Also in your URL, at the end of it, put   /rest

 

Good luck!

 

This worked! Thanks for posting!

Glad it helped! I know it took me a little while to work out most of the issues.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted 7 hours ago in Jira

Atlassian Research Workshop opportunity on Sep. 28th in Austin, TX

We're looking for participants for a workshop at Atlassian! We need Jira admins who have interesting custom workflows, issue views, or boards. Think you have a story to sha...

25 views 1 2
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you