• Community
  • Products
  • Jira
  • Questions
  • I got error "The Atlassian Marketplace server is not reachable. To avoid problems when loading this page, you can disable the connection to the Marketplace server."

I got error "The Atlassian Marketplace server is not reachable. To avoid problems when loading this page, you can disable the connection to the Marketplace server."

When I navigate to Find and Manage Add-ons, from the Confluence Admin page, I get the error:

The Atlassian Marketplace server is not reachable. To avoid problems when loading this page, you can disable the connection to the Marketplace server.

The error in the log is:

11 06, 2014 11:47:15 午前 org.apache.tomcat.util.http.Parameters processParameters Info: Invalid chunk starting at byte [182] and ending at byte [201] with a value of [=%E7%A2%BA%E8%AA%8D] ignored  Note: further occurrences of Parameter errors will be logged at DEBUG level.

2014-11-06 11:46:32,591 http-bio-8080-exec-8 INFO anonymous 706x9x2 f3t9xb 10.0.2.2 /plugins/servlet/gadgets/ifr [jira.gadgets.system.MarketingGadgetSpecProvider] IO error retrieving Atlassian JIRA News gadget from 'http://www.atlassian.com/gadgets/news.xml': Connect to www.atlassian.com:443 timed out 2014-11-06 11:46:59,500 http-bio-8080-exec-1 WARN miura 706x75x1 1ui8d12 10.0.2.2 /issues/ [atlassian.upm.pac.PacClientImpl] Error when querying application info from MPAC: com.atlassian.marketplace.client.MpacException: org.apache.http.conn.ConnectTimeoutException: Connect to marketplace.atlassian.com:443 timed out 11 06,

2014 11:47:15 午前 org.apache.tomcat.util.http.Parameters processParameters Info: Invalid chunk starting at byte [182] and ending at byte [201] with a value of [=%E7%A2%BA%E8%AA%8D] ignored  Note: further occurrences of Parameter errors will be logged at DEBUG level.

 

JIRA version is 6.3.1-x64

How can I solve this problem?

 

 

4 answers

It seems that Atlassian replaced the wildcard certificate a few weeks ago.

All connections made from my Confluence site will get denied with:

TLSv1 Alert (Level: Fatal, Description: Certificate Unknown)

 

Finally I found the problem in my case. The new root certificate was not in the java keystore. But this is not the problem in your case. At least not at this point.

 

 

Now, for your problem. The relevant message is "Connect to marketplace.atlassian.com:443 timed out". This means that your server could not create a TCP connection towards marketplace.atlassian.com on port 443. You should see connections in the state SYN_SEND if you run "netstat".

 

To debug this you have to rule out if it is a local problem or a remote one.

The easiest way to do it is to run: tcptraceroute marketplace.atlassian.com 443

The last line in the output will give you a hint about where the problem is.

I think your server problem is either a route misconfiguration or a firewall that is filtering the connection.

 

if you need to quickly test the connection (TCP+SSL) run: echo ""| openssl s_client -showcerts -connect marketplace.atlassian.com:443

You can also test (only TCP) with: telnet marketplace.atlassian.com 443

What should I import? I serched with the word "certificate" and I found add-on "Client Certificate Authenticator SSO". Is this add-on intermediate certificate that you say?

I commanded "tcptraceroute marketplace.atlassian.com 443" and got message "traceroute to marketplace.atlassian.com (131.103.28.7), 30 hops max, 443 byte packets 1 10.0.2.2 (10.0.2.2) 0.425 ms 0.178 ms 0.207 ms 2 pillar03.atlassian.com (131.103.28.7) 11.224 ms 10.734 ms 11.013 ms" What mean is this message?

pillar03.atlassian.com is the PTR record for the marketplace.atlassian.com's IP. The output of tcptraceroute is very strange. The strange thing is that you do not see any hops (routers) between your server and destination. My only explanation is that there is a kind of firewall, tunelling or transparent proxy that is changing the traffic between your server and marketplace. You could try to test also with: curl -I https://marketplace.atlassian.com/

I try with curl -I https://marketplace.atlassian.com/ and got message "curl: (7) couldn't connect to host" I will check firewall and proxy again.

Hi @shota miura,

maybe the marketplace server really is down? Have you tried to do it again?

Another problem comes with different baseUrls. If a baseUrl is configured (p.e. "localhost:2990/jira") and you call confluence via the ip (p.e. 127.0.0.1:2990/jira) and try to install a plugin via the marketplace it can cause problems.

I tried many times. But I constantly cannot connect to Atlassian Marketplace. And I don't want to install any plugin now. I tried JIRA101 and did "Configure workflows and screens". In Step 1. Import a workflow, as I Choose Add Workflow > Choose from Marketplace, got message " cannot access to Atlassian Marketplace referencing workflow". So I want to enable to access Atlassian Marketplace.

Have you tried connecting to the marketplace to install a plugin (just to see if you can connect there)?

Actually, I startuped JIRA on imaginary OS to test JIRA before I use on host OS. I can connect marketplace from host OS, but I cannot connect from imaginary OS.

Look like network issues to me

Are you behind a proxy server or a firewall?

Yes, I use firewall and proxy server. But I setted them to allow to connect to Atlassian Marketplace.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Nov 27, 2018 in Portfolio for Jira

Introducing a new planning experience in Portfolio for Jira (Server/DC)

In the past, Portfolio for Jira required a high degree of detail–foresight that was unrealistic for many businesses to   have–in   order to produce a reliable long-term roadmap. We're tur...

2,380 views 15 19
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you