I cant see many plugins for install on UPM

I can't see the plugins of the site marketplace after jira installation. My jira is installed in small instance at amazon and is proxed in nginx. What can be the problem?

2 answers

PS I use jira 5.1.3, Oracle Java 1.6 and ubuntu 12.04 server 64-bit

Hi, have you specified the proxy settings in the JVM? You'll also need to make sure that localhost is set to be a nonProxyHost.

Look at this answer https://answers.atlassian.com/questions/20251/using-jira-upm-through-download-proxy for more information.

You need -Dhttp.proxyHost= -Dhttp.proxyPort= -Dhttp.nonProxyHosts=

Base URL set correctly.

traceroute:

traceroute -4 -n marketplace.atlassian.com
traceroute to marketplace.atlassian.com (63.246.22.212), 30 hops max, 60 byte packets
 1  10.59.4.3  0.669 ms  0.645 ms  0.627 ms
 2  10.1.78.5  0.622 ms  1.093 ms 10.1.76.5  0.550 ms
 3  79.125.1.99  0.519 ms 79.125.1.97  0.896 ms  0.880 ms
 4  178.236.0.138  1.149 ms 178.236.1.4  0.700 ms 178.236.0.138  1.112 ms
 5  178.236.0.117  1.362 ms  1.353 ms  1.597 ms
 6  178.236.0.117  1.310 ms 178.236.0.121  1.692 ms 213.242.106.85  1.417 ms
 7  213.242.106.85  1.632 ms 4.69.153.234  1.488 ms 195.16.170.101  2.093 ms
 8  4.69.153.238  2.238 ms 4.69.153.242  17.350 ms 4.69.153.234  1.323 ms
 9  4.69.143.222  98.553 ms 4.69.153.242  17.614 ms 4.69.137.58  98.099 ms
10  4.69.148.146  110.941 ms 4.69.153.242  17.455 ms 4.69.137.54  97.136 ms
11  4.69.137.58  98.286 ms 4.69.137.54  97.145 ms 4.69.143.222  100.908 ms
12  4.69.143.222  100.030 ms  97.965 ms 4.69.148.146  112.293 ms
13  4.69.148.146  111.266 ms  110.843 ms 4.69.132.189  190.980 ms
14  4.69.132.185  116.708 ms 4.69.132.189  175.614 ms 4.69.140.193  111.840 ms
15  4.69.132.189  179.580 ms 4.69.132.185  116.699 ms 4.69.132.189  178.950 ms
16  4.53.160.186  118.203 ms 4.69.132.185  116.524 ms  117.917 ms
17  63.246.15.2  130.306 ms *  120.494 ms
18  * 63.246.15.2  118.836 ms  120.331 ms
19  * * *
20  * * *
21  * * *
22  * * *
23  * * *
24  * * *
25  * * *
26  * * *
27  * * *
28  * * *
29  * * *

Ping:

ping marketplace.atlassian.com
PING plugins.atlassian.com (63.246.22.212) 56(84) bytes of data.
64 bytes from 63-246-22-212.contegix.com (63.246.22.212): icmp_req=1 ttl=49 time=117 ms
64 bytes from 63-246-22-212.contegix.com (63.246.22.212): icmp_req=2 ttl=49 time=117 ms
64 bytes from 63-246-22-212.contegix.com (63.246.22.212): icmp_req=3 ttl=49 time=117 ms

^C
--- plugins.atlassian.com ping statistics ---
6 packets transmitted, 6 received, 0% packet loss, time 5005ms
rtt min/avg/max/mdev = 117.471/117.532/117.603/0.398 ms

Thx.

But, i don't use proxy. Maybe Amazon use proxy?

I tried set -Dhttp.nonProxyHosts=localhost, but the result remained the same.

I'd check your firewall/network. From your Amazon instance (EC2?) try to do a traceroute or similar and see if you can get to marketplace https://marketplace.atlassian.com

Also make sure the base URL is set correctly. It'll tell you in the general configuration section of the admin screen for JIRA.

I tried to view https://marketplace.atlassian.com in lynx and firefox on my Amazon EC2 instance - all good!

I use UPM 2.1.5, I'll upgrade manually now.

What log I should to look? catalina.out?

Do you see any errors in the logs? What version of UPM are you using? You can try downloading the latest from https://marketplace.atlassian.com/plugins/com.atlassian.upm.atlassian-universal-plugin-manager-plugin/ manually, upgrading it and see if it fixes it. UPM does seem to have lots of weird issues connecting from my experience and what I've seen.

I see a notice on the JIRA upgrade UPM, but when I click on the "update now" nothing happens

atlassian-jira.log

No result after upgrade.

only one warn in log:

2012-08-28 14:52:55,244 http-8080-1 WARN jira_admin 892x207x1 157c0y4 37.157.16.186 /rest/plugins/1.0/com.atlassian.upm.atlassian-universal-plugin-manager-selfupdate-plugin-key [atlassian.upm.pac.PacAuditClientImpl] Unable to log pluginUninstalled event to PAC: com.atlassian.plugins.PacException: 404

Now, I restart jira and view log

That 404 response sounds like it can't get to plugins.atlassian.com. It'd check if you have access to that too. However, marketplace is just an alias for plugins right now. Besides restarting after upgrading UPM I can't think of anything else. You might like to raise a support ticket with Atlassian on UPM.

There was an issue with 5.0.6 that got solved in 5.0.7.

I Use 5.1.3. Ping to plugins.atlassian.com and marketplace.atlassian.con - successful, but plugin search not work :(

Thanks for the help. I'll write to support.

If i try to search plugin, i get "No plugins matching your search criteria are available for installation in your JIRA instance."

Can you see ANY plugins? Remember that the marketplace will drop any plugin not flagged as valid for your install, and a lot of them aren't updated to 5.1 yet.

I see 9 plugins...and nothing more

I installed version 5.1.3 and it can not even support SVN install?

And more plugins?

I have install 5.1 and it all works well. What happened is that in 5.1.3 does not work most of the plugins?

I downgrade to 5.1.2 and the problem is gone

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Tuesday in Jira

Looking for anyone who made the switch to Data Center

The Jira Marketing team is putting together an ebook on migrating to Data Center. We're looking for pro tips on how you staffed your project team and organized your Proof of Concept. Share yo...

41 views 0 2
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you