How to use my BD Data - Can't login in Jira 4.3

Hello,

I installed the Jira 4.3 and I have made my connection to BD (SQLServer2005) through config.bat now need to use my data, for example the users.

But a problem that appears when you load the Dashboard and try to login with any user of my BD I can not do.

Anyone know how I can use my BD my users?

1 answer

0 vote

I'm not clear what you are trying to do here? What do you mean by BD? Is that the Jira database? What's a BD user got to do with a Jira user?

Hello Nic,

Thank you for your response.

Currently I have installed Jira 4.0 connected to a database SQLServer2005 (BD) within this BD i have my users Jira and some more tables that are of interest.

I am installing the Jira 4.3 per I need to make a Jira Upgrading to 5.x, I need to restore all my settings and my Jira users in Jira 4.3 to test and then reset it to Jira 5.x.

I used to reference the documentation for upgrading from SQL connection to load the page but I can not login with any user.

It is a task a little confused because I am new to Jira = (!

Ok, so let me repeat this back to you as I understand it.

  1. You've got a database with a set of Jira data in it, version 4.0
  2. You've got an application server running Jira 4.0 and connected to the database.
  3. You stopped the Jira 4.0 service, installed 4.3 and connected it to the old database.
  4. You are now having problems with the 4.3, in that you cannot log into it (using the same accounts you had under Jira 4.0)

Is that correct? If so, then we probably need to know

  1. The extent of the problem - is it ALL users?
  2. How functional the Jira service is? Is it giving you a login screen and then failing to let you in and complaining about a broken username/password, or is it some other error (like completely broken, or error pages when you click on something, or a license issue etc)?
  3. What does your log file say? Ideally, read the log from the first time you started Jira 4.3 to see if the upgrade ran into errors, but also see the current one when you're trying to log in.

It is exactly as you describe.

A. - There are many users and I have the password for all, but I tried with a 5 and I can't connect.
2.-Load Dashboard screen when trying to enter and gives us "the username and password are incorrect", reading the information on the web I found a copy of a file also osuser.xml I entered the folder that indicate and nothing, then I saw something about Active Directory, but every time I read more I get confused, of what would be the correct way to update my JIRA.
3. Check the log but I have not found anything that might help.

As the intention is to migrate to 5.x, I must stop in 4.3?? ... error stopped me here. What would you advise me?

Ah, excellent. Well, not excellent in that there's still no obvious problem, but it's good info.

What you've said tells us that Jira is probably running fine, but is failing to read the users for some reason. The possibilities I can think of in your situation are:

  • It's not looking at the right database
  • It thinks you've changed the authentication method and is now looking in the wrong place (for example, your old system used the internal Jira user list, but you've asked it to use LDAP now)
  • Your data is corrupt for some reason

I think the next things to look at are

Can you check that the database that the new Jira is connecting to definitely has data? A command-line or gui tool to connect directly to the database would be the best way to check this. Obviously, using the exact settings that Jira is trying to use to connect.

What sort of user data were you using in the old Jira and have you tried to change it?

Don't worry about the migration to 5.x yet. It's very likely that you would have the same problems, and whatever problems they are, so it's better to understand and fix them in 4.3 (in case there are more in a 5.x upgrade - if you can make 4.3 work, then the next upgrade should be less error prone)

I use the config.bat that allows me to do a test connection, attached image.

I also think it may be the method of authentication, I'm trying to set up ouser.xml.
The data are not corrupted, and I have not moved any data type, just want to do the installation and wish to connect to the database.

Previously it has been configured to who uses the tomcat, but I've made ​​a separate installation, this will be the problem?

That looks healthy, it's connecting to a database happily. I would like to check that the database it's connecting to is the Jira database (and not an empty one), but if it is, then we've ruled out most of the database issues. I doubt your data is damaged too - that's quite difficult to do and usually stops Jira from starting at all, so although we can't be 100% sure (unless you can check the user data), I think we're done with the database.

If you're working with osuser, that implies you're changing the way the user authentication is working - that's definitely the thing to concentrate on - what have you changed here between 4.0 and 4.3?

Now

Hola Nic,

I am doing the installation manual ...
Let's start from 0, I reinstalled the Jira5.0.6, and I copied all of Jira4.0 JiraHome, the problem I have now is with the web, you get an error when loading ... you've ever seen??

I have no up Tomcat service, so do not believe is that, on the other hand I changed the port to 1433 and others try and follow in the same, the log tells me "2012-06-22 23:50:06,804 jira-monitoring-plugin ERROR [jira.plugins.monitor.MetricsCollectorTask] Error running task

java.lang.IllegalStateException: ComponentAccessor has not been initialised"


but I have seen the plugin and if you are in the folder where it belongs.

So ... which would be the error?
I need to download and install this plugin??
if so, where I can download some link???

Weekend work = (!

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Julia Dillon
Posted Tuesday in Jira

Tell us how your team runs on Jira!

Hey Atlassian Community! Today we are launching a bunch of customer stories about the amazing work teams, like Dropbox and Twilio, are doing with Jira. You can check out the stories here. The thi...

244 views 1 18
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you