Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

How to move subtask of parent to new project after moving parent to new project?

I moved a parent ticket to a new project, and was hoping the subtask would move as well but it did not. So now I have a case where the parent and subtask have different projects (different keys) but still have the parent-subtask relationship.

How can I move the subtasks over to the new project as well?

2 answers

1 accepted

1 vote
Answer accepted

Have you tried going to the Sub-Task, select the 'Move' option and follow the steps? You can choose the same parent again, but this it will have the new project key.

Yes, I had tried that but it didnt work. When I chose the parent, it said this is already the parent for the subtask. The parent key is updated, but the subtask key is not.

Here it is a support issue about this matter.

Thanks. It seems the only workaround is to migrate it to a parent type issue, migrate to the correct project, then migrate back to a subtask, is this correct?

Mmh... It looks like a bug. A possible workaround could be to clone the subtask to the parent in the new project. Or moving to other parent and then move to the real one.

I though about it but I'm not finding how to migrate back to a subtask, did you found out how to?

This issue is marked as resolved, but not sure that seems like a great solution! Regardless. thanks for your help!

And just in case, most of the users of the Atlassian Answers aren't from Atlassian. We can only give tips or workaround or advice. If you want a change in the Jira you need to create a support issue on support.atlassian.com

Cheers!

You have to mark as answered in the right corner of the answer, the check button.

Yes, that will be the best workaround. Has it worked?

I tried to move subtasks along with their parents and Jira tried to keep the sub-tasks in the original Project.

To do a bulk move and get the subtasks moved I had to:

1) update the filter with "AND type != Subtask"

2) Go through the Move wizard

3) Subtasks were automatically included and were moved.

Above solution works perfectly fine.

 

Regards

Sudipta

Hi @John Minne1 , I tried the above steps, and moved to new project. the parent sub-task relationship is perfect, but the time log entered on the sub-task didn't get migrated. Has anyone come across such situation?

Thanks a lot for that advise @John Minne1 

It works perfectly as expected!

Suggest an answer

Log in or Sign up to answer
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you