Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,323,839
Community Members
 
Community Events
168
Community Groups

How to import sub-task which parent id already existed?

Edited

Hi all , 

I have a issue of import sub-task via csv , for example 

parent id , sub-task summary ,  sub-task other columns ...
111, test , ..

I get the parent id by export the csv , so I think parent id is correct and existing.
But get the response "doesn't have a valid parent id selection"

How can I import the sub-task ?

3 answers

Has this issue been resolved? I'm getting the same error reported above....and it was reported 3 years ago!

I haven't encountered the issue recently.  It appears this was a memory issue.  Per my note below, if I used a clean browser, it worked fine.  So the ability to import is working, but the error message was misleading. 

I was receiving the same error message suggesting invalid Parent IDs while attempting to import multiple sub-tasks using a Chrome browser with numerous tabs open.  After closing all other tabs and clearing the browser cache and cookies, the same import worked fine.

0 votes

Hello @PM_Rita

Thank you for reaching out.

I believe the error you are informing occurs when you use the issue navigator importer in the bulk operation menu as displayed in the screenshot below. Is it correct?

Screen Shot 2019-10-29 at 16.58.12.png

If that's the case, I can confirm this behavior is a known bug in JIRA Cloud application. We have already reported it with our development team to get it fixed:

The non-admin CSV Importer gives an error for the parent Id field 

Feel free to vote and watch the bug to receive notifications about its fix implementation.

For now, you can run the CSV import by navigating to JIRA Settings > System > External system import, where this bug does not happen. P.S: This option is accessible only by Jira administrators.

Let me know if you have any questions.

Hi @Petter Gonçalves ,

It does import subtask info successfully . 

But respones "  Unable to link issue from 16003 to 14953 with link named 'sub-task-link': Cannot find imported issue key for external id '14953'  " .

16003 is subtask issue id , and 14953 is parent id which I copy from the export csv.

Hello @PM_Rita

Sorry, but I think I didn't understand if you are still facing the problem.

If you are still facing it, can you please share with us the CSV file you are trying to import? Please, make sure you removed all the sensitive data from that.

Also, are you trying to import the issues to a Classic or a Next-gen project?

 Hello @Petter Gonçalves ,

 

I am facing the same issue as you have mentioned above. The error appears as

"Unable to link issue from 15077 to 15075 with link named 'sub-task-link': Cannot find imported issue key for external id '15075'

Could you please help advise? My project is classic. Thank you.

Suggest an answer

Log in or Sign up to answer