How to fix the columns in a filter list view for other users?

 

12 answers

1 vote

Go to the field selection setting, and you'll find there are three options - system, your settings and filter.  Select filter, then choose all the columns you need.  Rearrange them.  Save the filter.

Users visiting your filter will now see those columns.  They can change to their own settings if they want, or system, but your filter will present your settings to them first.

many thanks! the columns are choosed and the filter is saved, but when I send it to another user, he can not see the same filter list view, which I defined. Other users can see only 1 colum on the list view.

 

0 vote

How are you "sending" the filter to them?

via email

0 vote

No, sorry, what are you actually giving them as the filter?  What is the content of the email?

just a link to my filter. When the user navigate directly in JIRA to find my filter, he doesn't see the same columns on the list view.

actually the filter should be visible for all users. I can not understand the reason why another user can not see the same configuration of the filter with the same columns in the list view.

Other users can see all parts of the filter in the details view.

0 vote

Ok, is it a full link to the filter though?  Is the url a direct pointer to the saved filter, or is it a search definition?

it is a direkt link to the saved filter list view

0 vote

Could you give us the full url please?  Remove the base url bit at the front if you want.

here the url to the filter list view 

https://jira.company.de/issues/?filter=10303

and I see by filter details, that the filter is visible for everyone

0 vote

Mmm, that looks wrong.  Should be requestid  I think?

I had similar problem and seems finally solved. I wanted to set filter columns for other users and I don't have any columns settings option under the filter cog in list view or "Manage filters" options. When I clicked on "Filter" in the "Columns" search box nothing much actually happened. Also the button next to the filter name was only "Save as", not "Save" when I changed the columns.

Solution that worked for me:

- In filter list view go to "Columns" and switch from "My Default" to "Filters" (ignore that nothing really happened)

- change search criteria (for example in advanced mode I changed "order by" clause)

- hit "Save" button next to the filter name

(- if needed, change the search criteria back and save again)

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Published Monday in Jira Software

How large do you think Jira Software can grow?

Hi Atlassian Community! My name is Shana, and I’m on the Jira Software team. One of the many reasons this Community exists is to connect you to others on similar product journeys or with comparabl...

713 views 6 13
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you