How to disable mod_disk_cache in Jira

I need to disable mod_disk_cache. How can I do this from jira tomcat?

Please Help

Thanks for answers

2 answers

This widget could not be displayed.

Er, without more detail, I can't help but assume you're referring to the Apache web server module which is nothing to do with Jira or the application server it's running under (e.g Tomcat)

Could you explain what your setup is and maybe why you want to disable this (rather useful Apache) function?

ok. How can I change the apache config?

Jira application server is on Windows. I need to disable it because of https://confluence.atlassian.com/display/JIRAKB/Session+Abort+Errors+or+Users+Log+in+as+Incorrect+User+due+to+Apache.

I am wrong? Jira has own tomcat. I need to configure jira' s tomcat settings or I need to configure IIS settings because it is on windows server. It is complicated. What is the solution?

You're missing the point. It is not a Jira function. It is not a Tomcat function. It is an Apache function. It is not an IIS function.

You need to work through your Apache config.

Depends on where you configured it to keep the configuration.

We can't really help you with this much - it's your installation and your setup, and we don't know how you configured it.

Did you inherit this system from someone else?

I have a Jira installed on windows and I need to disable mod_disk_cache. That's simple. Which file I need to edit?

This widget could not be displayed.

Hi,

Assuming that you have access to apache server, you need to check the apache.conf file, and comment the line where the modiule is loaded if you want to disable the module from apache completly.

Look for this on apache.conf file:

LoadModule cache_module modules/mod_cache.so

This line should be commented with # and if the module is configured as apache documentation, there will probably be some lines where the module is loaded for each virtual host. These lines should also be commented.

If you want to disable this only for jira host the following line should be on apache:

CacheEnable http://jira_url

Just change it to:

CacheDisable http://jira_url

Then restart Apache service to load the new configuration.

Please give it a try and let's know how it goes.

Regards,

Celso Yoshioka

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted Wednesday in New to Jira

Are you planning to trial, or are currently trialling Jira Software? - We want to talk to you!

Hello! I'm Rayen, a product manager at Atlassian. My team and I are working hard to improve the trial experience for Jira Software Cloud. We are interested in   talking to 20 people planning t...

146 views 2 0
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you