How to debug delegated LDAP authentication

I have set up a delegated LDAP authentication agains the corporate LDAP and it behaves really strange.

  • With my LDAP user everything is absolutely fine
  • One guy can only log in with his old password (changed in LDAP several weeks ago)
  • Another guy can log in once, subsequent attempts are rejected

Unfortunately I haven't managed to get any LDAP debug output in the logs. What I already did is setting the following logs to DEBUG:

log4j.logger.com.atlassian.jira.login.security
log4j.logger.com.atlassian.jira.login
log4j.logger.com.atlassian.jira.web.action.util.LDAPConfigurer

The only debug output I can now see in the logs is "Authentication FAILED" - saw this already at the UI smile

 

Any Idea how I could get more output about the LDAP communication? I need to be sure that there is no issue at my JIRA configuration in order to open a ticket at our corporate LDAP.

1 answer

Did you ever get an answer? I have a similar problem.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Sep 18, 2018 in Jira

What modern development practices are at the heart of how your team delivers software?

Hey Community mates! Claire here from the Software Product Marketing team. We all know software development changes rapidly, and it's often tough to keep up. But from our research, we've found the h...

26,385 views 2 7
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you