Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

How do you change Rule Actor Permissions in JIRA Cloud so hyperlinks open the issue in question

As per the comment.

JIRA Cloud Automation for JIRA forces the rule actor to be Automation app user, however, it's unclear where the permissions (or the account) exists for Automation app user.

My many slack notifications send 'functional' links that ask you to log in when you click them, but you can't give permissions (it just brings you back to the same page) because the Automation app user doesn't have an account, and you cannot use any other account.

Anyone else figured out where / how to enabled the links to work (that is, how do I give the rule actor permissions to at least Open the alert links I am sending?)

2 answers

1 accepted

0 votes
Answer accepted

I've been able to solve this with Atlassian's help.  The issue is related to SMART VALUES.
I was using the example structure for the message found on the Automation for Jira site - however, the smart values are...smart, and I didn't understand what it was actually doing.

Instead of using {{issue.key}} (with a base URL before it), I need to be using {{issue.url}} and not forcing the instance URL.  

So, there were two problems, slack messages were trying to access the wrong instance of jira (wrong URL), and it was using a valid but not as useful (in my scenario) smart value.  

If you see this, replace the whole baseurl{{issue.key}} thing with just {{issue.url}}in the message payload, and it should send valid links.


Thanks Atlassian!

Small self-update.  I'm working with Atlassian Support, it appears there is a permission granted to groups that has something to do with why this occurs.
It's still not functioning as expected for me, but if you're reading this and are seeing the same thing(s), check out the atlassian-addon-browse-project permission. It should apparently be granted to the administrators group, which I think means that Atlassian Addons would have admin powers. 

I'll update my thread again when this is solved.

This was a red herring.  Just use {{issue.url}} (only that) as part of the message payload instead of using <baseurl>{{issue.key}}|{{issue.key}

Suggest an answer

Log in or Sign up to answer
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you