Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

How do I get locked screens to be visible on "Create XX" screens?

In our Jira instance, none of the locked fields show on any "Create XX" screen. Even though the screens and permisions schemes are configured to allow the field. 

In fact, when open the "Create Change" screen and click on the Configure Fields button followed by "Where is my field?" link. Populating the field with any locked field (e.g., Organizations) results in a screen that states the field should be visible (and it's not). See screen shot below.

This appears to be happening for all locked fields across our instance. We also have the Tempo Timesheets add-on installed. Could this be causing the conflict?

 

WhereIsMyField.png

2 answers

1 vote
Rachel Wright Community Leader Apr 14, 2017

Hi Fred,

I didn't know the answer to your question but was currious so I looked into it a little bit.  The field in your screenshot, "Organizations", is for Service Desk customer portal requests.  I found this related feature request: https://jira.atlassian.com/browse/JSDSERVER-4723

It seems the field doesn't display from within JIRA, but will in the Service Desk customer portal (assuming you have one.)  I was able to reproduce your issue on a Cloud instance that doesn't even have JIRA Service Desk.

Hope this helps or at least leads you to more info,

Rachel Wright

Rachel,

Wow! Thanks so much for digging that up (and so quickly too). I'm fairly new to the Jira Admin world and I've been spending the last two weeks (off and on) trying to get that field to show up on the create screen. I was going crazy thinking that something wasn't configured correctly.

What I would really like to do is have Jira ServiceDesk auto-populate the Organizations field to a specific value "All XXX Users" after creation. However, since it's a custom field, you can't do that easily in the stock post function of a transition.  Any idea on the best way to do that? We have the ScriptRunner add-on (trial) installed but I'm still struggling on what the right approach would be. 

<removed, please delete>

Suggest an answer

Log in or Sign up to answer
TAGS

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you