How do I enable the Jira API?

I turned on 

Accept remote API calls

in the system settings.  However, from what I read the API is on a different port?  I dont see another listening port in my netstat output.

 

3 answers

I may have just answered my question.  I spun up another instance and was able to get a response from the API. My other instance was on my mac, which isn't supported. :/ 

Hi,

JIRA REST API uses the same port as JIRA itself. When you turn on the "Accept remote API calls" it does not open any news ports afaik, but enables the part in JIRA that accepts API calls

Thanks for the confirmation Sash.

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Posted Wednesday in Jira

Join our webinar: How 1B+ feature flag events helped us build the new Jira

Every time you release software, there's a bit of risk – that there's a bug, that something breaks, or that the feature doesn't resonate with customers. Feature flagging helps make high stakes s...

93 views 0 1
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you