Has anyone else upgraded to 5.0.4 yet?

Upgraded to 5.0.4 last night and so far we are unable to assign or close issues.

I have only been administering JIRA for a few months and have upgraded to every release with no problems but this one seems to have caused some issues.

I have attached some screenshots.

Any suggestions?

3 answers

1 accepted

Reinstalling JIRA 5.0.4 resolved my issues. However, I had to help the install along.

First, I encountered a error with the zip file creation during the backup of the install and system folders. I manually stopped the JIRA service before launching the installer to resolve that.

Second, I encountered a folder/file creation issue with "attach.dll". I had to manually created the "JIRA" foler under "C:\Program File (x86)\Atlassian\" in order for the new install to continue.

Other than that the install completed successfully and JIRA is operating normally.

Could not execute action

[AssignIssue]:com.atlassian.jira.bc.issue.comment.CommentService.isValidCommentBody(Ljava/lang/String;Lcom/atlassian/jira/util/ErrorCollection;Z)Z<p><small><small><pre>java.lang.NoSuchMethodError: com.atlassian.jira.bc.issue.comment.CommentService.isValidCommentBody(Ljava/lang/String;Lcom/atlassian/jira/util/ErrorCollection;Z)Z at com.atlassian.jira.issue.fields.CommentSystemField.validateCreateComment(CommentSystemField.java:362) at com.atlassian.jira.issue.fields.CommentSystemField.validateParams(CommentSystemField.java:324) at com.atlassian.jira.web.action.issue.AbstractCommentableIssue.doCommentValidation(AbstractCommentableIssue.java:88) at com.atlassian.jira.web.action.issue.AssignIssue.doValidation(AssignIssue.java:89) at webwork.action.ActionSupport.validate(ActionSupport.java:391) at webwork.action.ActionSupport.execute(ActionSupport.java:162) at com.atlassian.jira.action.JiraActionSupport.execute(JiraActionSupport.java:82) at webwork.interceptor.DefaultInterceptorChain.proceed(DefaultInterceptorChain.java:39) at webwork.interceptor.NestedInterceptorChain.proceed

I have upgraded to this same version (from version 5.0.0) and now all literals show up as their variable names.

Things like "workflow.designer.toggle.labels" instead of "Toggle Labels" in the workflow designer and alike appear.

Also: I use a multi-lingual installation (Spanish - US English) and with this upgrade the system got confused and now mixes Spanish and English texts througout the application.

Some help would be great!

thanks,

Jacques.

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Julia Dillon
Posted Apr 17, 2018 in Jira

Tell us how your team runs on Jira!

Hey Atlassian Community! Today we are launching a bunch of customer stories about the amazing work teams, like Dropbox and Twilio, are doing with Jira. You can check out the stories here. The thi...

816 views 2 19
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you