Getting libjvm.so: cannot restore segment prot after reloc during Jira Upgrade

I am trying the upgrade process and have downloaded the appropriate bin for 32 Bit CentOS.

 

when I execute the bin file, shortly after I get libjvm.so: cannot restore segment prot after reloc.

The process then stops.  Any recommendations?

2 answers

This widget could not be displayed.

Not enough information - we need the full error message - the first two or three lines, not just the part of the first line you have given here.

But, I'm guessing the rest of it starts with "permission denied"?  If so, then there's a very good chance that SELinux is blocking the execution, and you need to fix that.  I'm really not an SELinux expert, so I don't know if this is the right answer, beyond the "it has worked for me" criteria

restorecon /yourjavainstallation/lib/i386/client/libjvm.so

Or

chcon -t textrel_shlib_t /yourjavainstallation/lib/i386/client/libjvm.so
This widget could not be displayed.

Thanks for that.  I tried changing the Seliux context but didn't work.  The full error I get is

 

Unpacking JRE ... Starting Installer ... Error: dl failure on line 893 Error: failed /usr/local/jira7.1.1.bin.17701.dir/jre/lib/i386/server/libjvm.so, because /usr/local/jira7.1.1.bin.17701.dir/jre/lib/i386/server/libjvm.so: cannot restore segment prot after reloc: Permission denied

 

What I'm intrigued about is the bath it is trying to work on must be a path that it is trying to create during the installation as it doesn't exist.

Yes, it does look like it's trying to access something that's not yet there.

This sounds (and feels) a bit wrong, but could you try disabling SELinux during installation.  That would be temporary, and I'd be happier if your network was disconnected while doing it, but I think it might need trying.

Suggest an answer

Log in or Sign up to answer
Atlassian Summit 2018

Meet the community IRL

Atlassian Summit is an excellent opportunity for in-person support, training, and networking.

Learn more
Community showcase
Posted Aug 06, 2018 in Jira Service Desk

A is for Activate: Share your top Jira Service Desk onboarding tips for new users!

Hi, everyone! Molly here from the Jira Service Desk Product Marketing Team :).  In the spirit of this month's  august-challenge, we're sourcing stories of Jira Service Desk activation fro...

578 views 25 15
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you